Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running endian firewall release 2.2.rc3 and I have just installed sarg to monitor bandwidth usage but I sarg daily index.html is not being created. Has anyone come across such scenarios?

share|improve this question
add comment

4 Answers 4

You could also look at SRG, written when SARG stopped being maintained a few years ago.

share|improve this answer
    
Endian firewall wont install pacakages easily, its a linux distro modified to suite the packages shipped with endian –  Rungano Jun 24 '09 at 6:52
add comment

First you need to check the permissions for the squid logs, then the permissions for the output directory and finally if your web publishing directory is available.

Double check the sarg.conf file and look if you are using the correct paths.

HTH

share|improve this answer
    
Permissions are fine, I think one of the problem is the date, its using the date 1Jan1970...this now annoying me big time! I have uninstalled it deleted all the files associated with it, reinstalled again nothing seem to be working! –  Rungano Aug 7 '09 at 14:37
add comment
up vote 0 down vote accepted

append the access.log file in sarg.conf to access_short

share|improve this answer
add comment

Have you changed anything in endian's output log format? SARG will parse default log format only. That could explain why it doesn't show correct time...

Was using SARG with Squid, everything was fine until I changed Squid log format to something readable. And found that it should not even look like default, it has to be default.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.