Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When one of our users is on holiday they will set their Out of office message and change the Out of office rule to forward all emails received to a colleague. This has always worked very well for us while we were using Exchange 2003, but now we have some of our Mailboxes on Exchange 2010 the behaviour seems to have changed (for the worse).

Exchange 2003

Mailboxes located on Exchange 2003 will send the following message to the person defined in the Out of office forwarding rule. Notice that the original senders email address (in this case my personal email address) is shown.

enter image description here

Exchange 2010

When the Out of office forwarding rule kicks in for Mailboxes on Exchange 2010 the email is forwarded on as normal, but notice that the original senders email address is not shown on the forwarded message.

enter image description here

This causes us a problem, because the whole idea of having emails forwarded on to somebody else is so they can deal with the enquiries and orders that come in while the other person is on holiday. If the person dealing with the forwarded emails needs to contact the customer, Exchange 2003 made this easy by showing their email address - Exchange 2010 seems to make this impossible.

Is there an option we can change to make the original senders email address show, have Microsoft removed this feature or is there at least some workaround we can implement that will allow us to have what we need?


Update 1

I have tested this with various combinations of Outlook and Exchange and here are the results of the test. As you can see, something has definitely changed in the way Exchange 2010 behaves with forwarded Out of office messages. Does show/Does not show is relating to the original senders email address.

+--------------+---------------+---------------+ 
|              | Exchange 2003 | Exchange 2010 |
+--------------+---------------+---------------+
| Outlook 2003 |   Does Show   | Does not show |
| Outlook 2007 |   Does Show   | Does not show |
| Outlook 2010 |   Does Show   | Does not show |
+--------------+---------------+---------------+

Here is the (mildly sanitised) output of Get-RemoteDomain | fl. I'm not entirely convinced this has anything to do with it though, as these settings are all for outgoing mail to domains other than our own.

RunspaceId                        : 1002c62b-9f50-47a0-8862-1d635c4dbdba
DomainName                        : *
IsInternal                        : False
TargetDeliveryDomain              : False
CharacterSet                      : iso-8859-1
NonMimeCharacterSet               : iso-8859-1
AllowedOOFType                    : ExternalLegacy
AutoReplyEnabled                  : True
AutoForwardEnabled                : True
DeliveryReportEnabled             : True
NDREnabled                        : True
MeetingForwardNotificationEnabled : False
ContentType                       : MimeHtmlText
DisplaySenderName                 : True
TNEFEnabled                       :
LineWrapSize                      : unlimited
TrustedMailOutboundEnabled        : False
TrustedMailInboundEnabled         : False
UseSimpleDisplayName              : False
NDRDiagnosticInfoEnabled          : True
AdminDisplayName                  :
ExchangeVersion                   : 0.0 (6.5.6500.0)
Name                              : Default
DistinguishedName                 : CN=Default,CN=Internet Message Formats,CN=Global Settings,CN=WIDGETS,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=corp,DC=acme-widgets,DC=com
Identity                          : Default
Guid                              : 0f601b72-7249-47cb-8f51-321c5d070d7f
ObjectCategory                    : corp.acme-widgets.com/Configuration/Schema/ms-Exch-Domain-Content-Config
ObjectClass                       : {top, msExchDomainContentConfig}
WhenChanged                       : 25/01/2011 17:20:34
WhenCreated                       : 10/10/2007 12:17:57
WhenChangedUTC                    : 25/01/2011 17:20:34
WhenCreatedUTC                    : 10/10/2007 11:17:57
OrganizationId                    :
OriginatingServer                 : dc2.corp.acme-widgets.com
IsValid                           : True

Update 2

The suggestion by Holocryptic to use the option Keep message intact seems to have done the trick. It's a pain to have to do this to each computer, but so far the best "solution" I've had. Ideally I'm still looking for something server side like Exchange 2003 was, but Holocryptic is most likely to end up with this bounty.

share|improve this question
    
Do you notice this behavior with other forwarded mail? Or just with OOF? –  Holocryptic Feb 25 '11 at 18:30
    
I just left the office as I posted this, but I will check it out on Monday. Could you define "other forwarded mail" please @Holocryptic –  Ben Pilbrow Feb 25 '11 at 19:34
    
@Ben, when forwarding other mail items, you'll see smtp or mailto links in the first forwarded message and not subsequent messages in the chain (if there's been multiple emails back and forth). Here's a screenshot of what I mean. picasaweb.google.com/108798697118943580107/…. Does your forwarded mail act like that, or does it show the same symptoms of your OOF? I'm afraid my current answer probably won't do you any good, but I'll edit it when we get closer to a solution. –  Holocryptic Feb 25 '11 at 20:16
    
Oh right, just regular forward (sorry I thought you meant some other type of auto-forwarding)! No, we just have names, no addresses show on a normal forward. –  Ben Pilbrow Feb 25 '11 at 20:21
    
Also, what version of Outlook are your users using? It may have bearing on the problem. –  Holocryptic Feb 25 '11 at 20:21
show 11 more comments

1 Answer

How do you have your forwarding rule set up? Have you tried setting the forward method to "keep message intact"? Via this link.

It's possible Rollup 2 fixes the issue, but you'll want to go to rollup 5 (as apparently that allows you to uninstall Exchange after installing any previous rollup. Weird.)

share|improve this answer
    
There's another option in that rule setup: Insert Message As Attachment. That sounds similar to what I ask users to do when sending me problem messages, as it's the only way to preserve all the headers. Maybe that would work better for OOF; since it would both be clear that it's an OOF forwarded message, but you can open the attachment and reply directly to the original sender? –  SmallClanger Mar 2 '11 at 15:19
    
@SmallClanger, it might be. In the comments in the question, I posted a link to someone who was having similar problems. Might not just be Ben... –  Holocryptic Mar 2 '11 at 21:11
add comment

protected by Iain Nov 3 '11 at 18:04

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.