Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got a Ubuntu Server 10.10 with 2 network interfaces with a cable plugged into both going to switches on completely different networks with different routers. One network is the 10.1.10.X network with a separate gateway/router - the server has an IP of 10.1.10.50 with the gateway IP of 10.1.10.1. The other interface is 10.2.10.X, IP 10.2.10.50, gateway 10.2.10.1.

All my Mac machines are on the 10.2.10.X network, and all servers on the 10.1.10.X. The ONLY connection between the two is this machine. From a Mac in my office, I CANNOT ping any computer on the 10.1.10.X network except the Ubuntu machine I'm talking about. However, under the Shared column in Finder, I can see every server on the other network listed. That makes me believe that somehow this Ubuntu machine is letting certain requests span both networks, which is a security problem.

Hope this is enough info.

share|improve this question
    
What OS do the servers run that you're trying to hide? What machines access the servers, and how? It's unclear whether Unbuntu is passing some packets between the two subnets, or maintaining its own list of the servers it sees, which Finder can find. –  Paul Feb 26 '11 at 3:50

3 Answers 3

Do you have Samba running on the Ubuntu Server? I would guess this has to do with SMB browsing where Samba announces all the other SMB servers it sees on both interfaces, possibly acting as a WINS server.

share|improve this answer

Unless packet forwarding is enabled or IPtables rules are in place Ubuntu shouldn't be forwarding any packets from one interface to the other. Can you try running traceroute from the Mac to the Server.

share|improve this answer

I think you're seeing avahi(the linux implementation of Bonjour) sharing the hostnames of hosts it sees on each network. You can turn this off, but you won't see this Ubuntu server in your Mac's Shared column.

You should be able disable it by running

stop avahi-daemon

If that helps, ypu can prevent it from running at boot by renaming /etc/init/avahi-daemon.conf to something that doesn't end in .conf .

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.