Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Iv been having a trouble trying to get my Solaris 10 server to authenticate against an eDir server.im managed to Set up my linux(RHeL,SLES) servers to authenticate against the ldap Server.which works fine.

Here is my configuration Files.

ldapclient list:

NS_LDAP_FILE_VERSION= 2.0
NS_LDAP_BINDDN= cn=proxyuser,o=AEDev
NS_LDAP_BINDPASSWD= {NS1}ecfa88f3a945c22222233
NS_LDAP_SERVERS= 192.168.0.19
NS_LDAP_SEARCH_BASEDN= ou=auth,o=AEDev
NS_LDAP_AUTH= simple
NS_LDAP_SEARCH_SCOPE= sub
NS_LDAP_CACHETTL= 0
NS_LDAP_CREDENTIAL_LEVEL= anonymous
NS_LDAP_SERVICE_SEARCH_DESC= group:ou=Groups,ou=auth,o=AEDev
NS_LDAP_SERVICE_SEARCH_DESC= shadow:ou=users,ou=auth,o=AEDev?sub?objectClass=shadowAccount
NS_LDAP_SERVICE_SEARCH_DESC= passwd:ou=auth,o=AEDev?sub?objectClass=posixAccount
NS_LDAP_BIND_TIME= 10
NS_LDAP_SERVICE_AUTH_METHOD= pam_ldap:simple

getent passwd works fine:

root:x:0:0:Super-User:/:/sbin/sh
daemon:x:1:1::/:
bin:x:2:2::/usr/bin:
sys:x:3:3::/:
adm:x:4:4:Admin:/var/adm:
lp:x:71:8:Line Printer Admin:/usr/spool/lp:
uucp:x:5:5:uucp Admin:/usr/lib/uucp:
nuucp:x:9:9:uucp Admin:/var/spool/uucppublic:/usr/lib/uucp/uucico
smmsp:x:25:25:SendMail Message Submission Program:/:
listen:x:37:4:Network Admin:/usr/net/nls:
gdm:x:50:50:GDM Reserved UID:/:
webservd:x:80:80:WebServer Reserved UID:/:
postgres:x:90:90:PostgreSQL Reserved UID:/:/usr/bin/pfksh
svctag:x:95:12:Service Tag UID:/:
nobody:x:60001:60001:NFS Anonymous Access User:/:
noaccess:x:60002:60002:No Access User:/:
nobody4:x:65534:65534:SunOS 4.x NFS Anonymous Access User:/:
tlla:x:2012:100::/home/tlla:
test:x:2011:100::/home/test:
thato:x:2010:100::/home/thato:

pam.conf

login auth sufficient pam_unix_auth.so.1 #server_policy
login auth sufficient /usr/lib/security/pam_ldap.so.1 try_first_pass
login auth required pam_dial_auth.so.1

rlogin auth sufficient pam_rhosts_auth.so.1
rlogin auth requisite pam_authtok_get.so.1
rlogin auth required pam_dhkeys.so.1
rlogin auth required pam_unix_cred.so.1
rlogin auth sufficient pam_unix_auth.so.1
rlogin auth sufficient /usr/lib/security/pam_ldap.so.1 try_first_pass

rsh auth sufficient pam_rhosts_auth.so.1
rsh auth required pam_unix_cred.so.1
rsh auth sufficient pam_unix_auth.so.1 #server_policy
rsh auth sufficient /usr/lib/security/pam_ldap.so.1 try_first_pass

other auth requisite pam_authtok_get.so.1
other auth required pam_dhkeys.so.1
other auth required pam_unix_cred.so.1
other auth sufficient pam_unix_auth.so.1
other auth sufficient /usr/lib/security/pam_ldap.so.1 try_first_pass

passwd auth required pam_passwd_auth.so.1
passwd auth sufficient pam_unix_auth.so.1

ssh account sufficient pam_unix.so.1
ssh account sufficient /usr/lib/security/pam_ldap.so.1 try_first_pass

other account requisite pam_roles.so.1
other account sufficient pam_unix_account.so.1
other account sufficient /usr/lib/security/pam_ldap.so.1 try_first_pass

other password required pam_dhkeys.so.1
other password requisite pam_authtok_get.so.1
other password requisite pam_authtok_check.so.1
other password required pam_authtok_store.so.1
other password sufficient pam_unix.so.1
other password sufficient /usr/lib/security/pam_ldap.so.1 try_first_pass

Local Authentication Works But LDAP Authentication Doesn't Work.

share|improve this question

migrated from superuser.com Feb 26 '11 at 3:45

This question came from our site for computer enthusiasts and power users.

1  
Please provide your /etc/nsswitch.conf –  Benoît Feb 1 '11 at 11:00
    
If getent passwd returns ldap users, nsswitch.conf is correct. –  jlliagre Feb 1 '11 at 11:25
    
You should post a user entry ldif and the directory server access log files during an authentication. –  jlliagre Feb 1 '11 at 11:26

1 Answer 1

Hi guys Thanks for the Responses.

i Found what was missing from Completing my mission to authenticate Solaris 10 to LDAP Server.

After having at the log files like jlliagre pointed out.i picket up this entry on the Directory Server during authentication.

 Rejecting unencrypted bind on cleartext port in nds_back_bind, err = 13

Which then lead me to this Disabling Simple Bind Options

After Disabling "Require TLS for Simple Binds with Password"

LDAP Authentication on Client Worked.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.