Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How do I fix this error on Ubuntu 10.04 ?

Reading package lists... Done
Building dependency tree       
Reading state information... Done
postfix is already the newest version.
The following packages were automatically installed and are no longer required:
  libaprutil1-dbd-sqlite3 libcap2 apache2.2-bin libapr1 libaprutil1-ldap libaprutil1 php5-common
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up postfix (2.7.0-1) ...

Postfix configuration was not changed.  If you need to make changes, edit
/etc/postfix/main.cf (and others) as needed.  To view Postfix configuration
values, see postconf(1).

After modifying main.cf, be sure to run '/etc/init.d/postfix reload'.

Running newaliases
newaliases: warning: valid_hostname: numeric hostname: 202002
newaliases: fatal: file /etc/postfix/main.cf: parameter myhostname: bad parameter value: 202002
dpkg: error processing postfix (--configure):
 subprocess installed post-installation script returned error exit status 75
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
 postfix
E: Sub-process /usr/bin/dpkg returned an error code (1)

Even if I reboot, the same error shows up. Thanks for the help..

share|improve this question
    
sudo nano /etc/postfix/main.cf && /etc/init.d/postfix reload worked for me –  kgpdeveloper Feb 26 '11 at 4:59
add comment

2 Answers

it clearly states the error is in /etc/postfix/main.cf. Open it and fix myhostname value to match hostname command. Then run service postfix reload and check how it is.

share|improve this answer
add comment

This might be caused by configuring an invalid hostname on first installation. The debconf keeps the values in its database and uses those for future installations also (I guess?), which causes this problems even if you remove or/and purge your postfix.

Try to purge your configuration with following command echo PURGE | debconf-communicate postfix and try apt-get install postfix again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.