Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have two Ricoh printers/copiers setup for IP printing in the office.
Before this week there were no problems printing to them.
Now a handful of them (All running Vista, not sure if it is every Vista computer or not, It seems like I would hear more from users if that was the case), see both printers as being offline. All the PC's running XP have no problems printing. When this first occurred a reboot was able to get the printer to appear online, but that is no longer the case. (and at the time I thought only one computer was having the issue) I have removed the printers, reinstalled the latest drivers and there is no change on the Vista machines. I am currently using the same version of a RPCS driver on both VISTA and XP. As a work around I could setup the printers on a 2003 Server, but I don't see why IP printing should just stop working out of the blue like this. The printer can be reached by IP from all computers and the web interface is accessible and reports no errors.
Does anyone have any ideas?

share|improve this question
    
Do the "Standard TCP/IP Ports" on both the Vista and XP machines have the SNMP option enabled and the community set the same way? –  Evan Anderson Jun 11 '09 at 15:11
    
That is a big 10-4. –  notandy Jun 12 '09 at 20:39
    
+1 for a clean concise well-written question that happened to be my exact issue. –  Robert Jun 24 '10 at 23:30
    
I'm having this same problem with a IPP printer (CUPS server). So no SNMP to disable. Any other ideas? –  ptman Sep 20 '11 at 8:17

10 Answers 10

up vote 5 down vote accepted

If all else fails, you can disable SNMP monitoring in the printer's TCP port properties. You won't be notified when the printer becomes ACTUALLY offline, but you won't get false positives anymore.

share|improve this answer
    
This does work. –  notandy Jun 12 '09 at 16:00
1  
+1 this solved my issue as well. It doesn't explain why I had it in the first place but I'll take the answer. :) –  Robert Jun 24 '10 at 23:29
1  
This also happens if the SNMP community string is anything other than "public" –  Tom O'Connor Jan 26 '12 at 17:42

Hmm.

We've seen somewhat similar issues here, but outside of a few high-end plotters that we print directly to IP for, we're hosting the rest of them off of a printserver, and your symptoms are not exactly the same as what we've seen, but close enough. I've got a few ideas for you, in the hopes that they'll help but nothing really conclusive :)

1.) Try restarting the local print spooler service on the workstation in question. (ex: net stop "Print Spooler" && net start "Print Spooler"). See if that has any effect.

2.) Navigate to the driver properties of the printer, on the workstation, select "Advanced", select "Print Processor", try setting "WinPrint" to RAW, or changing to MS_XPS and select RAW.

3.) Check the port on the local workstations that the printer is configured to use, is it valid or did it mysteriously dissapear? (We've seen THAT one before. Man, what a pain!)

4.) It's a long-shot, but see if a local firewall is blocking it. Disable any local firewall/ip filtering and test to see if it works. We've seen this before, but specifically in this situation: We're running Symantec EndPoint on all workstations and in some instances, the local Windows default firewall was showing as enabled and running and doing some funky, funky blocking. :)

Either way, good luck!

share|improve this answer
    
Restarting the spooler in a local machine works .... thx –  Dihuso Feb 5 '11 at 6:29

Did you change the default snmp community (public) ? Put it back online through the file menu once the printer is opened (or right click on it first.)

share|improve this answer
    
Nope, no changes to the SNMP. Toggling offline/online makes no difference. –  notandy Jun 12 '09 at 15:59

This vista forum has two suggestions, one is to try and setup the printer port as 'persistent' using the dos command

net use LPT1 \\[printservername]\P1 /persistent:yes

The other is to apply the hotfix #934455 available from microsoft. This should be included in SP1.

Another site suggests restarting the Print Spooler service, which should reset the offline status. Also in the properties of Print Spooler / Recovery try setting the 'Recovery on Subsequent failures' to Restart. The default is it stops restarting after 2 failed attempts.

share|improve this answer
    
They are running SP2. –  notandy Jun 12 '09 at 15:59
    
Did you try the other suggestions? –  Jack B Nimble Jun 12 '09 at 19:35
    
I am not using a print server so that eliminate net use. I tried restarting the print spooler service and it didn't fix the issue. –  notandy Jun 12 '09 at 20:38
    
But are you still using IP printing, so it still creates a virtual port. –  Jack B Nimble Jun 12 '09 at 21:16

I had the same problem with a 2008 Server machine (basically Vista Light), I had to reboot it before it would print. Talk about aggravation. There is a registry setting hidden deep within the bowels of HKLM

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet\Hardware Profiles\0001\System\CurrentControlSet\Control\Print\Printers\

Find the offending printer entry, then find the entry named.

PrinterOnLine

Edit it. Changing it to the magical value of

1

This makes my cry for CUPS ... or even lpr ...

share|improve this answer
    
Hmm, I'll have to check this out. –  notandy Jun 12 '09 at 20:41
1  
If you try it, don't use HKLM\System\ControlSet001, but HKLM\System\CurrentControlSet, which is a link to the ControlSet that is actually active on your machine. –  Massimo Jun 15 '09 at 21:50
    
Thanks for the correction. –  Joseph Kern Jun 16 '09 at 10:24

In my case printer was seen by windows 7 as offline when someone was trying to print using wireless lan. In wire lan everything was ok and also it worked on Linux even withs wireless lan connection.

I found out that widows 7 use snmp to determine printer state, after unblocking snmp communication (of course only for printer) on our firewall it works perfectly whether client is in wire or wireless network and on with every OS.

share|improve this answer

Had the exact same issue in W2K3. I unchecked the snmp option and the printer went back online. (Had the regedit as well.)

share|improve this answer

the problem might be that your router is reassigning the ip that the printer has acquired. this might be because you turn off your printer after use and also your router. you only have to reassign an ip to your printer and my advice is that you reserve it by your router.

and never face this problem again.

share|improve this answer

Had the exact same issue in server W2K8 also. Local network, no routers, no filters, no firewalls, no natting. All on the same broadcast segment. Since last friday (5/24) all network printers stopped printing from the printer queue in the server. Restart print spool service had no effect. Unchecking the snmp option in the server's port settings did the job.

share|improve this answer

I could resolve the issue by starting the SNMP Trap service which I had disabled manually (Windows 7).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.