Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have server controlled by Debian 6.0. I installed and configured redmine some time ago, and now configured svn server.

Now i'm trying to configure redmine to be able to view svn repository. URL is:

Connection is not working, log show this error:

Error parsing svn output: #<REXML::ParseException: No close tag for /lists/list>

Google says that its common error, and its possible to fix it by permamently accept of server certificate so i did it and nothing. Still dont work.

Later, i added

store-plaintext-passwords = no

in file


I did this (and cert accept) for both root and www-data users. Nothing helped, still got error in redmine

The entry or revision was not found in the repository.

What else i can do with it?

share|improve this question

2 Answers 2

This is a bug in Redmine, IIRC. It doesn't handle self-signed certificates very well at all.

I ended up following the instructions here and got mine working. In short, create a directory for subversion to dump its configuration to, run it once manually, then edit the subversion_adapter.rb in redmine's lib/redmine/scm/adapters/ folder in order point it at that config directory. I didn't / couldn't follow those directions to the letter, I doubt you'll be able to either, so be prepared to go off-script if need be.

share|improve this answer

Adding to what Peelman said (as I can't comment on his answer), for me, adding the --config-dir directive to the subversion_adapter.rb file was the final piece of the puzzle (i'd tried various ways of running svn and permanently accepting the certificate, but redmine wouldn't find the config).

To clarify, the complete steps were:

1: Modify Redmine's subversion adapter script

# pico /usr/share/redmine/lib/redmine/scm/adapters/subversion_adapter.rb

Change the line in that file with command line args

from: str << " --no-auth-cache --non-interactive"

to: str << " --config-dir /usr/share/redmine/svn/.subversion --no-auth-cache --non-interactive"

2: Ensure subversion client accepts the self-signed cert permanently

# sudo -u www-data svn --config-dir /usr/share/redmine/svn/.subversion list https://<my-repository-url>

When prompted, select the option to accept certificate (p)ermanently

To complete the test, enter your subversion credentials when prompted (hit enter at the first username prompt for www-data and it'll ask again for another username). When prompted select "no" to saving your credentials unencrypted (the necessary acceptance of the SSL cert has already been saved by this point). You can verify that by looking inside the /usr/share/redmine/svn/.subversion directory, where you'll find a directory called svn.ssl.server with a new file in it.

Obviously if your copy of redmine runs as a user other than www-data you should sudo using that user instead. Make sure the user you sudo to has the necessary permissions to create an /svn directory inside the redmine directory - otherwise you may not be given the option to (p)ermanently accept the certificate when you run the svn client.

3: Restart Apache

In my case, redmine is running using mod_passenger under apache, so it was necessary to restart apache to pick up the changes to the redmine subversion adapter script (prior to the restart I was still seeing errors in redmine).

# /etc/init.d/apache2 restart

4: Browse to a project's /repository in Redmine

Everything should now be working

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.