Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a problem while installing and configuring MySQL cluster running on Ubuntu 10.10

This is configuration for Cluster management





Id=1                            # the NDB Management Node (this one)

Id=2                            # the first NDB Data Node
DataDir= /var/lib/mysql-cluster

Id=3                            # the second NDB Data Node


and this is configuration for both node :

ndb-connectstring=        # the IP of the MANAGMENT (THIRD) SERVER

ndb-connectstring=        # the IP of the MANAGMENT (THIRD) SERVER

After running all node and management, and I use ndb_mgm, the type 'show' command, and something appear like this :

ndb_mgm> show
Connected to Management Server at: localhost:1186
Cluster Configuration
[ndbd(NDB)] 2 node(s)
id=2    @  (mysql-5.1.39 ndb-7.0.9, Nodegroup: 0, Master)
id=3    @  (mysql-5.1.39 ndb-7.0.9, Nodegroup: 0)

[ndb_mgmd(MGM)] 1 node(s)

id=1    @  (mysql-5.1.39 ndb-7.0.9)

[mysqld(API)]   1 node(s)

id=4 (not connected, accepting connect from

look at two last line.. not as what look like (see at point 4)

anyone have ever had this problem ?

share|improve this question

Hmm First what is very important... the management server and the mysql/storage server cannot be the same. I hope you have here really different Servers.

But your problem looks like that you have a configuration problem on your nodes or not started the nodes correct.

On first Start or for testing.

mkdir /var/lib/mysql-cluster cd /var/lib/mysql-cluster /usr/local/mysql/bin/ndbd --initial /etc/rc.d/init.d/mysql.server start

its really important that the directory exists and you initial it. And for notice its a bit confusing the storage engine and mysql.server are different things. One is really the storage witch hold the data and the other is the client what you can see on bottom. Both must be started.


use --initial ONLY if its really important.

But for notice. In MySQL Cluster is one small problem. You cannot change Tables in running storage engine. So if you have a Table with the NDB storage engine you cannot add a field for example.

For this you need to change it to myisam for example change the table and then change it back to ndbcluster engine i think when you have a finished application its ok. But for many projects you have a lot of problems.

I have tried MySQL Cluster for days and read a lot of documentations and its a really cool system but complicated to run and manage. But i have used an older version of mysql cluster like the new 7.1 its possible that there are many things different.

I hope you can solve the problem.

share|improve this answer
Thank you @Stony. I have read carefully the documentation. and I made it identically. but the problem is the cluster doesn't work. I think the problem is in 2 last line in my management 'show' command. take a look at **[mysqld(API)] 1 node(s) id=4 (not connected, accepting connect from ** but, as i saw in documentation, it should be like this ** [mysqld(API)] 2 node(s) id=4 (Version: 4.1.9) id=5 (Version: 4.1.9) ** – Firman Feb 27 '11 at 4:28
sorry for my late reply, this is because the mysql deamons are not running or not configured correct then he can't find it. What i have seen is that you gave all of them an ID. When you make this give the both mysqld an ID [MYSQLD] Id = 4 [MYSQLD] Id = 5 i hope this is the problem. In the Tutorial nothing have an Id then he can generate it for its own. And then restart mysqld under init.d for sure look in the mysql errorlog if there are any problems. – Stony Feb 27 '11 at 22:04
have you solved this problem? @Firman. – Stony Feb 28 '11 at 9:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.