Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Set up a wordpress page the other day following this guide. The site was up and running, loading quickly and all was well, until today.

Suddenly, loading the site takes forever and doesn't even work properly, the page shows up in an incomplete fashion.

I tried rebooting the instance but that didn't help.

The only actions I've taken on the server is to create an elastic IP, and to point a domainname to that IP. But I don't see how that could've slowed down the page.

Any thoughts on what could have caused this and on a solution to the problem?

share|improve this question
    
Forgot to mention; I am running an AMI that has windows server edition installed. –  Emil Feb 27 '11 at 16:47
    
What size instance are you running the site on? –  BenGC Feb 27 '11 at 20:23
    
micro-instance. –  Emil Feb 27 '11 at 21:53

3 Answers 3

The Amazon's Micro instances don't scale well with WordPress and other software that uses databases heavily. If you would like to keep the micro instance, I'll recommend install a caching plugin for WordPress or some caching software like Varnish to reduce the impact your database is making on your instance resource consumption (you're probably hitting 100% CPU and being hammered for that). If you can change your instance, try the small or medium instances and you'll have no problem with your WP installation.

share|improve this answer

I came across this issue today (I run a micro instance as well)... my WordPress site was working perfectly until I created an elastic IP, and in doing that, my public DNS name was changed. I noticed that when I tried to access my WordPress site, it was trying to access my old public DNS name.

Apparently, when you set up your WordPress site, part of the installation process grabs the site's public DNS name and stores it in the WordPress MySQL table. It was a simple fix for me... loaded up phpMyAdmin, went to the wordPress database, and modified some values in the wp_options table. I ran the following MySQL query (make sure you back up your database just in case):

update wp_options set option_value = replace(option_value, 'ec2-<old_ip>', 'ec2-<new_ip>')

Where <old_ip> is the old IP that was used in your public DNS, and <new_ip> is the new one. This will find and replace your old ec2 DNS name and replace it with the new one... voila! All should be well.

share|improve this answer
    
...may I ask why I was downvoted? –  incutonez Nov 13 '13 at 3:55
    
Probably because your answer doesn't seem to actually address the OP's problem, but reads like an anecdotal story sympathizing with the OP. –  Magellan Nov 13 '13 at 4:31
    
It looks fine to me, though one doesn't really need the "me too" part here. –  Falcon Momot Nov 13 '13 at 4:47
    
@Magellan: how does it not address the problem? I was getting slowness with WordPress after creating an elastic IP... exactly what the OP was experiencing. –  incutonez Nov 13 '13 at 4:50

Just go into your wp-config.php file and add the line
define('RELOCATE',true);
right above the line that says 'That's all! Stop editing!'
Then login to WordPress at your NEW ip address. It will work fine. Then just go to
Settings->General
and update your site URL to the correct info. Be sure to scroll to the bottom and click Save. Your site will again function normally. Be sure to delete or comment out the define('RELOCATE',true); line that you added in wp-config.php
Source: my own experience and wordpress.org support forums

share|improve this answer
    
This is all true, and this works very well, but it's completely irrelevant to the question. –  Michael Hampton Aug 24 at 11:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.