Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a LAN and the router is the DHCP server. We have a server with Windows SBS 2008, it has the IP address 192.168.1.2 while the router has the IP address 192.168.1.1.

I have tried to add a client computer to the SBS domain by visiting http://connect from the client computer. But that page doesn't exist. I can visit http://192.168.1.2/ then the default startpage for IIS7 is shown. I'm logged in as a local Administrator on the computer that I tries to add to the domain.

How do I add the client computer to the SBS 2008 domain?


UPDATE: I have now set the Windows SBS 2008 as DHCP Server. I can connect to http://connect/ on an Windows XP client, but I have problem with a Windows Vista client, it can not connect to http://connect/ and I have tried to renew the IP address and flush the DNS Cash with ipconfig /flushdns but it doesn't help.

How can I solve this?

share|improve this question
    
Microsoft strongly recommends that the SBS Server act as the DHCP server. Is there a specific reason why you're not? –  gravyface Feb 28 '11 at 15:01
    
@grayface: Yes, since the network existed before the server was installed today. I can try to change the DHCP server to the SBS 2008 after worktime tonight. –  Jonas Feb 28 '11 at 15:10
1  
Seriously, do this. With SBS 2008, don't stray from the recommendations too far (i.e. follow the checklist, use SBS Console vs. dsa.msc, etc.). –  gravyface Feb 28 '11 at 15:15
add comment

3 Answers

up vote 2 down vote accepted

You should really use SBS2008 as your DHCP server, as gravyface noted in his comment. Regardless though, you also need to ensure that the clients are pointed to DNS on the SBS2008 box directly. You could either modify DHCP settings on the router or (preferred) switch to using the DHCP on the server which will likely already be configured for you.

share|improve this answer
    
Ah, I will try that after working time tonight. –  Jonas Feb 28 '11 at 15:11
    
I have use SBS 2008 as DHCP Server now, but I still can't connect a Windows Vista cliet, see my update. Is there any command to see what DNS server the client is using? It is using the SBS2008 as DHCP Server now. –  Jonas Mar 1 '11 at 9:19
    
Problem solved. The client that couldn't connect to SBS2008 had a DNS server set manually, I changed to using the DHCP settings and it worked. Thanks. –  Jonas Mar 1 '11 at 9:35
add comment

You should specify the domain name in your DHCP server as well. Otherwise, the connect URL isn't going to resolve properly.

share|improve this answer
add comment

First, set the SBS server as the DHCP server for the clients. This isn't required but it's recommended. Make sure to set up and activate a valid scope with the appropriate options.

Second, on the workstation in question, set the "DNS suffix for this connection" field on the DNS tab of the Advanced TCP/IP properties for the NIC to the SBS domain name. Make sure the client is configured to use the SBS server for DNS. When the client tries to resolve the name "connect" it won't work unless the client appends the SBS domain name to it's query for the name "connect". I've run in to this on every SBS2008 install I've done.

share|improve this answer
    
Really? I've never had to do this on the 3-4 SBS 2008 installs I've done so far. A release/renew to get a new IP from SBS 2008 and good to go. –  gravyface Feb 28 '11 at 15:18
    
Well... thinking about it, if you follow Jason's advice then my advice shouldn't be neccessary. –  joeqwerty Feb 28 '11 at 15:33
    
True. Yeah, I never really stray far from the recommended SBS configuration (even though it pains me to do it that way sometimes) because something invariably breaks down the road. –  gravyface Feb 28 '11 at 17:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.