Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I have had the EasyPHP WAMP running fine for the past month, but I just followed MySQL's advice to put a password on 'root' user and now when I try to access MySQL from PHPMyAdmin I get the message: #1045 - Access denied for user 'root'@'localhost' (using password: NO). I have tried 2 suggested solutions involving editing the file in the phpmyadmin folder.

(1) following the instructions in EasyPHP Support FAQ #52:
Changing: $cfgServers[1]['password'] = ''
To: $cfgServers[1]['password'] = 'mynewpassword'
(2) following a suggestion posted here:
Changing: $cfg['Servers'][$i]['AllowNoPassword'] = false;
To: $cfg['Servers'][$i]['AllowNoPassword'] = false;
Which should make MySQL prompt for a password. I have also tried combining this with:
Changing: $cfg['Servers'][$i]['auth_type'] = 'config';
To: $cfg['Servers'][$i]['auth_type'] = 'http';

None of this has had any effect. The easyPHPadmin page continues to give the following parameters, (which surely it should update in acc with the config file) even when changes (1) or (2) have been made (and after restarting the computer):

MySQL parameters (default MySQL account) - Host : 'localhost'
- Username : 'root'
- Password : '' (no password)
- Path to the database root (datadir) : C:\Program Files\EasyPHP-5.3.3\mysql\data\

Any help on this much appreciated! Regards, Nimbus

share|improve this question

migrated from Feb 28 '11 at 19:07

This question came from our site for professional and enthusiast programmers.

marked as duplicate by Chris S Mar 20 '13 at 5:50

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

How are you connecting to MySQL? By default, the root account isn't permitted access via TCP sockets - only local domain unix sockets. What does show grants for root@localhost return if you access MySQL directly via the monitor? – Marc B Feb 28 '11 at 14:29

I had this issue also. It sounds like you are almost there, although I'm not sure if my solution will work for you (I'm new at EasyPHP too).

I'm on Vista Business and EasyPHP There is a note on the EasyPHP admin screen "Due to incompatibilities with Windows Vista/Seven, 'localhost' is no longer used. Use '' instead." This note appears in tooltip when hovering over the question mark next to Hostname.

For me, the following did it:

  1. adding the password
  2. setting AllowNoPassword = false
  3. $cfg['Servers'][$i]['host'] = ''; (This was already set like this for me)

Also, make sure you are editing the correct -- mine is in EasyPHP-\phpmyadmin folder.

*Note, I am still looking into possible security issues with this. EasyPHP is definitely designed for a dev, not production environment. *

share|improve this answer