Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

# yum install subversion subversion-devel neon neon-devel

While trying to install some packages with yum – as shown above – I get the following error

Transaction Check Error:
  file /usr/share/locale/de/LC_MESSAGES/libpq.mo from install of postgresql-libs-8.1.22-1.el5_5.1.i386 conflicts with file from package postgresql-libs-8.1.11-1.el5_1.1.x86_64
  file /usr/share/locale/es/LC_MESSAGES/libpq.mo from install of postgresql-libs-8.1.22-1.el5_5.1.i386 conflicts with file from package postgresql-libs-8.1.11-1.el5_1.1.x86_64
  file /usr/share/locale/fr/LC_MESSAGES/libpq.mo from install of postgresql-libs-8.1.22-1.el5_5.1.i386 conflicts with file from package postgresql-libs-8.1.11-1.el5_1.1.x86_64
  file /usr/share/locale/pt_BR/LC_MESSAGES/libpq.mo from install of postgresql-libs-8.1.22-1.el5_5.1.i386 conflicts with file from package postgresql-libs-8.1.11-1.el5_1.1.x86_64
  file /usr/share/locale/tr/LC_MESSAGES/libpq.mo from install of postgresql-libs-8.1.22-1.el5_5.1.i386 conflicts with file from package postgresql-libs-8.1.11-1.el5_1.1.x86_64

Now, the point is, if I try to run yum-complete-transaction, it wants to remove 130 packages(!). How can I get past this error without removing all those packages which spans from bash to openssl to yum!

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

Older versions of yum would install both x86_64 and i386 packages by default. Try

# yum install subversion.x86_64 subversion-devel.x86_64 neon.x86_64 neon-devel.x86_64
share|improve this answer
    
Thanks! That worked :) –  eriktm Feb 28 '11 at 21:08
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.