Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a DIR-625 Wireless Router for my home network. We have several PCs connected and all get excellent speeds but for some reason, the 2 Apple notebooks I have connected drag when loading up web pages. Proximity to the router has been ruled out. Is there something the Apple computers have in common that would be causing this? It is very annoying. One is a MacBook (white) and the other is the brand new MacBook Pro (13"). Both have the same problem. I am probably not putting enough detail but I don't know a lot about this. Any ideas? Possible router setting?

UPDATE:

I just noticed that when I change from "mixed B, G, N" to, for example "G only", the connection on the Macs increase. I have a few devices stuck on B still so it's not a permanent solution for me, but I thought that was interesting.

share|improve this question
add comment

5 Answers 5

up vote 0 down vote accepted

I have run into problems before where apple hardware will insist on running at the speed of the slowest device on the network. So your Apple laptops are seeing the devices that are using wireless B and are defaulting to that setting. I don't know why or how to fix it short of putting your apple devices on their own network segment. Obviously you can test if this is the problem by removing the wireless B devices from the network and reconnecting your Apples to see if you get better speeds.

share|improve this answer
    
Looks like this is what is happening. Fortunately I was able to get rid of the Wireless B cards on my network, then I set to G-only and the speeds are much better. –  Brian David Berman Jun 11 '09 at 18:56
    
What is involved with the dedicated apple segment idea you mentioned? I am a programmer who is usually over at StackOverflow so even coming over to ServerFault for me was stepping out of my element, so please be kind. –  Brian David Berman Jun 11 '09 at 18:59
    
You need a second wireless router which you connect to your "main" router and assign a to a different subnet. You put the Apple machines under that router and then set a permanent route in the "main" router so that it can find those addresses. –  Catherine MacInnes Jun 12 '09 at 20:29
add comment

The first place I'd check would be actual network connectivity, to determine where in the stack the comms issue lies. Pull up a terminal, and run the equivalent of 'sudo ping router-ip -i .01'. This will send out lots of quick pings to the router. See if you get persistent packetloss, and if the time is abnormal (Anything over 20-50ms round trip time). If that checks out OK, try larger packets by adding -s 1460 to the command. That'll send out large ping packets, and you can see if you get packetloss or if the rtt jumps a large amount. If both those check out no problem, the issue is higher in your network stack and you should start by troubleshooting Safari.


You should probably segment your networks off so that you're not running B/G/N on the same SSID. Try setting your wireless-N router to 5 Ghz N-only operation. Then, get ahold of a cheap or used 802.11g router that you can have handling B/G on 2.4 Ghz. Set its LAN IP to one more than your wireless-N's IP (i.e. wireless-N on 192.168.1.1, wireless-G on 192.168.1.2). Turn off the DHCP server on the wireless-G router. Then, connect the LAN sides of the two routers with a cat5 patch cable. This usually helps prevent speed issues seen when wireless devices are operating off a single SSID on 802.11b, g, and n.

share|improve this answer
add comment

Try lowering the MTU on the router (wireless settings). You could also try to plug the laptops directly to the router with ethernet cable and see if the problem persists (to rule out the wireless settings).

share|improve this answer
add comment

Activity Monitor (in /Applications/Utilities) has a network tab that'll show you your throughput.

I expect that running AP Grapher will be your best bet in this case.

Two CLI thoughts come to mind, however. You could compile and run iftop to see your network throughput (iftop -i en1 to graph your wireless access), and running

/System/Library/PrivateFrameworks/Apple80211.framework/Versions/Current/Resources/airport -I

will give you some stats on your wireless connection.

share|improve this answer
add comment

Which browser? Safari only? If it is the same with Firefox?

There was some issues with Safari and a router box common in Germany (Fritzbox) that lead to slow connection speeds. This was caused by a non-standard way the Fritzbox DNS server responded to the multiple queries Safari sends out and a failure in Safari's handling of this. It could be solved by either switching to Firefox or configuring another DNS server instead the default on (which is normally your router, who sents out this information with the DHCP address).

So, if Firefox behaves better, set up the DNS server of your provider in the network preferences, instead of the IP address of your router.

share|improve this answer
    
Safari and Firefox. Browser was ruled out. –  Brian David Berman Jun 11 '09 at 16:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.