Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have heard about a vulnerability in BIND. See here: http://www.isc.org/software/bind/advisories/cve-2011-0414

The issue appears to be with certain versions and my version (9.3.6) is earlier than any versions they mention. I did a yum install on BIND and it downloaed and installed the same version 9.3.6 which seems old.

So old in fact that I got to worrying. I know that CentOS doesn't upgrade versions and that instead it patches existing versions of applications. But where do you go to get the patches or are they downloaded periodically in the background. Am I to assume that the keepers of my CentOS repos are patching BIND (and other apps) so that when I update or install using YUM I get the latest safe version.

Without a new version number how do I know I'm patched?

share|improve this question

1 Answer 1

cve-2011-0414 affects ISC BIND 9.7.1 through 9.7.2-P3, so if you are running 9.3.6 you are not vulnerable.

http://packetstormsecurity.org/files/cve/CVE-2011-0414

see also https://bugzilla.redhat.com/show_bug.cgi?id=679496

"Not vulnerable. This issue did not affect the versions of bind as shipped with Red Hat Enterprise Linux 4, 5, or 6."

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.