Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am using bluehost shared hosting. I want to setup bugzilla. There are lot of guides on google search. As i having a tons of stuff on bluehost. I am looking for a trustable source. Anybody who is having step by step guide to install bugzilla. I have shell access.

PS:-- for precautions i have a backup. But i dont want to mess up the things.

EDIT

I was trying:--

Stuck here:--

I was just going with the flow:--

  1. ./checksetup.pl
  2. /ramdisk/bin/perl install-module.pl --all
  3. vi ./localconfig (modified db, dbuser, dbuserpass)
  4. ./checksetup.pl

and after that by script :--

  • Tables created
  • some directories, css files and atlast

    Creating ./lib/.htaccess...
    Creating ./template/.htaccess... 
    Creating .htaccess...
    Creating contrib/.htaccess...
    Creating t/.htaccess...
    There is no such group: apache. Check your $webservergroup setting in
    ./localconfig.
    

Back on terminal.. What next??? I think it should ask me about administrative username and password etc

share|improve this question
4  
Please dont ask for step-by-step guides. It shows that you are not willing to learn anything. And, quite honestly, we're not a support department who writes documentation. –  pauska Mar 1 '11 at 11:58
    
@pauska please check the question. I have specified what i did. Please check first and then say. –  Mohit Jain Mar 1 '11 at 12:01

2 Answers 2

The error message specifies clearly what the problem is. In your localconfig file, there is a setting for the value $webservergroup (which is the Unix group your webserver runs with the permissions of). You have it set to "apache" (which, I believe, is the default) but there is no group in the system with that name. So you need to set it to the true name of the group your webserver runs as.

I am not familiar with bluehost but another common value is "www-data". To find out, do ps aux | grep apache and look at the first column. One may be root, but the next few will be the value you want.

Gerv

share|improve this answer
    
thnks.. for bluehost u need to make that entry blank.. thanks for ur help –  Mohit Jain Mar 2 '11 at 9:26
    
The comment in the localconfig file warns against setting the value to "", as it can be a security risk. Some files are made world readable/writeable, and so (depending on how bluehost works - does it give out accounts, or entire VMs?) other bluehost users on the same machine may be able to change your files. –  Gervase Markham Mar 2 '11 at 11:00
up vote 2 down vote accepted

For bluehost u need to make that entry blank

means in bugzilla/localconfig

 $webservergroup="apache" 

change it to

   $webservergroup=""
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.