Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to stop and then disable a remote task from a build script. The remote server is Server 2k8. The client running the script is Windows 7. Both machines are joined to the domain.

When I run schtasks /Change /S remoteServer /TN "theTask", I get an error ERROR: The specified task name "theTask" does not exist in the system. If I run this command locally, everything works. I've verified that the domain user account I am logged into on my computer has administrator privileges to the remote computer.

If I run schtasks /Query on the remote computer, I get a listing of all scheduled tasks. If I run the same command remotely with the /S switch, only two legacy tasks (Google update tasks) return.

My initial thought was that this could be a permissions error, but when I try to run schtasks using the /u switch, I get ERROR: The request is not supported, which makes no sense because both the client and server are running the modern version of windows scheduler. I'm very confused.

What do I need to do to allow schtasks remote access to ALL the tasks on a server?

Edit: schtasks seems to only be returning the list of "v1" style tasks.

share|improve this question

2 Answers 2

up vote 4 down vote accepted

Found it! Turn off windows firewall or enable the Remote Scheduled Tasks Management firewall exception.

That note is buried way down in here: http://msdn.microsoft.com/en-us/library/bb736357(v=vs.85).aspx

share|improve this answer

This might also happen if the user specified in the Principals-->Principal-->UsedId is different from the one who is trying to execute the task.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.