Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to stop and then disable a remote task from a build script. The remote server is Server 2k8. The client running the script is Windows 7. Both machines are joined to the domain.

When I run schtasks /Change /S remoteServer /TN "theTask", I get an error ERROR: The specified task name "theTask" does not exist in the system. If I run this command locally, everything works. I've verified that the domain user account I am logged into on my computer has administrator privileges to the remote computer.

If I run schtasks /Query on the remote computer, I get a listing of all scheduled tasks. If I run the same command remotely with the /S switch, only two legacy tasks (Google update tasks) return.

My initial thought was that this could be a permissions error, but when I try to run schtasks using the /u switch, I get ERROR: The request is not supported, which makes no sense because both the client and server are running the modern version of windows scheduler. I'm very confused.

What do I need to do to allow schtasks remote access to ALL the tasks on a server?

Edit: schtasks seems to only be returning the list of "v1" style tasks.

share|improve this question
up vote 6 down vote accepted

Found it! Turn off windows firewall or enable the Remote Scheduled Tasks Management firewall exception.

That note is buried way down in here:

share|improve this answer
This did not work for me. Also, this does not explain why some tasks are returned and not others. – brianary Mar 16 at 17:00
Specially port 135. – Ivan Chau Jun 13 at 1:51

This might also happen if the user specified in the Principals-->Principal-->UsedId is different from the one who is trying to execute the task.

share|improve this answer

Your computer and remote computer might have different windows/schtasks version. The steps below solve my 'ERROR: The request is not supported' issue.

  • Copy schtasks.exe from the remote computer at c:\windows\system32 to your computer
  • Run the copied schtasks.exe instead of your local schtasks.
share|improve this answer
copying a different version of the scheduled tasks executable wouldn't be considered best practice. This also doesn't answer the questions as to why a remote server fails to return the correct information when queried. – Patrick Oct 8 '15 at 8:37

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.