Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

freebsd-update command prints updating entries after it downloaded. But it shows them with more. So I have to press some spaces to continue. Is there a way to avoid this behavior? I want to execute update fully automated manner.

share|improve this question
add comment

1 Answer 1

Before doing any of this make sure you are familiar with the freebsd-update process, possible ramifications, and requirements. Like any automated update there is a chance it will screw up.

Create the file /usr/local/etc/periodic/weekly/912.freebsd-update with the following:

#!/bin/sh -
#
#

# If there is a global system configuration file, suck it in.
#
if [ -r /etc/defaults/periodic.conf ]
then
    . /etc/defaults/periodic.conf
    source_periodic_confs
fi

case "$weekly_freebsd-update_enable" in
    [Yy][Ee][Ss])
        echo ""
        echo "Updating system via freebsd-update:"

        freebsd-update cron install;;

    *)  rc=0;;
esac

exit $rc

Don't forget chmod +x 912.freebsd-update
Enable it by adding weekly_freebsd-update_enable="YES" to /etc/periodic.conf
Your normal periodic report will contain the log results from the operation (e-mail to root by default).

The number 912 is arbitrary, it's just the number I use. You can pick anything in the 900 range and it should work fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.