Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So I just setup a box running Solaris Express 11 to use as a ZFS server for the home network and I have a small issue with the built-in VNC server.

On a fresh reboot if I try and log in via VNC the client hangs. If I switch the monitor over to the solaris box it is hanging at a prompt requesting authorization to the keychain (so it can verify my VNC password). Once I have entered authentication once via the local console it works fine. It's only really come up as I've been rebooting more often trying to get the hang of the services mechanism, but it's mildly annoying still.

Do I just need to setup a different remote server, or is there some way I can configure the existing one (I do want to stay with something that requires some sort of authorization (password, user pass, or some sort of token)). Would like windows & os X clients.

share|improve this question
    
Is this that gnome keyring? I haven't tried 11 express yet. –  JOTN Mar 2 '11 at 0:17
    
Yep, the Gnome keyring –  ChrisBenn Mar 2 '11 at 3:21
1  
My solution so far for gnome keyring has been just to disable it. It seems like it's really only designed for a desktop system. –  JOTN Mar 2 '11 at 15:04
    
Doh, for some reason didn't consider that. If you want to post it as a reply I'll accept it as the answer (I'll test it out this afternoon when I get off of work) –  ChrisBenn Mar 2 '11 at 22:00
add comment

1 Answer 1

up vote 0 down vote accepted

Disabling gnome keyring didn't work, but I did finally get this going. For the sake of completeness, to be able to VNC into my Solaris 11 Express box after a server restart without first needing to go to the local console I had to

1)Turn on GDM autologin in /etc/gdm/custom.conf I had to add under the [daemon] header AutomaticLoginEnable=true
AutomaticLogin=username
GdmXserverTimeout=15

2)Remove the password from the gnome keychain go to package manager and search for "seahorse"
install/run
right click on the "Default" keychain and change password to a blank password.

Now finally I can VNC into my box without having to login to the local console first after a restart.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.