Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have been trying to get Blackberry Entreprise Server 5.0 running on my Windows 2008 VM. It seems to work, I can now add users and find them into Active Directory.

The next step for me would be to assign a device to a user, this device do not have any data plan. However, according to the Administration Guide, it is apparently possible to activate it over an entreprise Wi-Fi network.

To do this, an SMTP service need to be configured, and will be use by the Blackberry Router.

I never had to deal with SMTP server and I am really not familiar with the concepts.

As I said, BES is installed on a VM under Windows 2008R2. I have an Exchange Server with AD on a server under Windows 2008R2. This server is on the same domain than the VM.

On the BES's VM, I installed an SMTP Server with IIS6, then I tried to send a message manually via telnet. The message is added to the queue but is never received in the mailbox of the receiver... On the event viewer of the VM I have an error message: "SMTP was unable to connect to an LDAP server".

I have tried every single configuration for the SMTP Server, I enabled the LDAP routing and gave him the parameters of the Exchange Server. I checked with nslookup if I can resolve it, it works...

I did not find any thread anywhere with somebody who has down this before...

If anybody could help me with this I would be very grateful.

P.S.: Sorry if my English is not perfect, I am working on it.

share|improve this question

3 Answers 3

The web console (https://server:3443 ISTR) actually includes functionality to use an ActiveX control in IE to activate the device directly against the BES. It's probably the easiest way to go about it, no need to setup separate profiles for each device.

This will allow the device to communicate with BES over Wi-Fi even without a BES plan.

share|improve this answer
    
Thank you this is exactly what I need. –  user72691 Mar 2 '11 at 13:26
    
Super - in that case click the little checkbox beside my answer :) –  MikeyB Mar 2 '11 at 16:14
    
thanks, didn't know about it. –  Vick Vega Mar 2 '11 at 19:33

I'll second the "Use Blackberry Desktop" advice; this seems a lot more complicated than it's worth.

That said, this article seems to cover the WiFi activation process well. From the information stored there, it looks like the SMTP server is just being used as a relay for the ETP messages -- your Exchange server (or other internal mail system) should work just fine for this purpose, instead of needing to set up a new SMTP server just for this.

Alternatively, you could simply set the "Use MX Lookup to obtain SMTP server" option mentioned in the article to have it skip the local SMTP and just send the mail straight to RIM.

share|improve this answer
    
I tried to use the "Use MX Lookup to obtain SMTP server" option. I did not understand it was going straight to RIM, but this is something I don't want because I do not have any data plan. –  user72691 Mar 2 '11 at 13:27

BES devices will require a data plan in order to receive emails sent to the users. I would suggest getting a data plan first in place, then activate it. As well you can activate using desktop application. Start with article to configure BES.

share|improve this answer
    
Everything has been configured, included everything in your link. But according to the administration guide it is possible to activate a device without data plan: "Users can activate Wi-Fi® enabled BlackBerry® devices over an enterprise Wi-Fi network in environments that have the following characteristics: • BlackBerry devices can connect to the enterprise Wi-Fi network but cannot connect to the BlackBerry® Infrastructure." To do this I need to setup an SMTP server. –  user72691 Mar 1 '11 at 22:06
    
You have SMTP server already, in the Exchange. Allow relay, if not configured already, in Exchange to allow message delivery from the VM with the BES server. –  Vick Vega Mar 1 '11 at 22:10
    
Yes the relay is already configured. Unfortunately it does not change anything to my problem, after configuring the OTA WIFI Activation on the Blackberry Router, I am trying to make the Entreprise Activation on the device and I still get the message "Activation request failed. A service connection is unavailable.". Maybe an authentification problem... I am able to connect to the Outlook Web Access and send and receive e-mail so the SMTP server IS running and working correctly... –  user72691 Mar 2 '11 at 14:28
    
I also try to manually send an email with telnet, connecting to the exchange SMTP connector and it works fine. The documentation of BES suggests it is possible to activate the device without dataplan this way but it seems that it need something more than the SMTP server... –  user72691 Mar 2 '11 at 15:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.