Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I downloaded util-linux-2.12b package and and built it. I need to use the login utility in the login-utils folder.

But after running it, it gives a "Login incorrect" for every user even with correct username/password.


Now it seems the utility is not working with /etc/shadow passowrds.

if I disable the shadow passwords by

#pwunconv

Its is working fine, while after enabling it with

#pwconv

It stops working again. :(

share|improve this question
2  
Why aren't you using CentOS packages? You should paste some relevant log lines and configuration into your question, as your question currently says "login doesn't work. fix it." We need to know what login is doing and how it is set up. –  David Pashley Jun 11 '09 at 16:54
    
David, I have modified the question with latest pointer i have on the problem. –  M.N Jun 12 '09 at 7:32

2 Answers 2

Hey if use RHEL that will have all you require. Or you can look form lfs project were open source ppl are there to help with code.

rajat

share|improve this answer
    
I am using RHEL, and I have downloaded their source code as i need to patch something. But this problem is inherent in it even in the untouched version. I gues there are people here to help me too! :) –  M.N Jun 12 '09 at 7:32
    
Mohit have u use H/W is certify from RHEL and ver are using bcoz i was faceing a same pro with my old laptop using RHEL 5.2 update (desktop)..Rajat –  Rajat Jun 12 '09 at 7:46

Have you built the package with the source RPM? Seems that you might have compiled it by hand (the tar.gz) without shadow password supprt, which will explain the fact that when disabling shadow password it works.

If you do it with a source RPM you should install it, extract the util-linux sources (under /usr/src/redhat/SOURCES), patch and close it up again. Another, even better option is to add your patch to the spec file and then build.

share|improve this answer
    
I did build it using the .tar.gz package, I did not find any configuration documentation.. even ./configure --help isn't working. Can you please suggest how to enable shadow passwords. –  M.N Jun 12 '09 at 7:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.