Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is basically my first post on serverfault, although I do watch Stackoverflow multiple times. I've recently purchased a VPS and started to configure it.

Since most of my working are design related, I wish to use FTP as many times as possible.

I've installed pure-ftpd, remove it after an issue where I couldn't logon with a new username created. I've installed vsftpd, couldn't get it to have a username, remove that.

But, it seems that pure-ftpd is still running.

Some commands reports that may be helpful:

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name
tcp        0      0 *:ftp                       *:*                         LISTEN      11359/pure-ftpd (SE
tcp        0      0 localhost.localdomain:smtp  *:*                         LISTEN      11633/sendmail: acc
tcp        0      0 *:mysql                     *:*                         LISTEN      3512/mysqld        
tcp        0      0 *:http                      *:*                         LISTEN      14065/httpd        
tcp        0      0 *:ftp                       *:*                         LISTEN      11359/pure-ftpd (SE
tcp        0      0 *:ssh                       *:*                         LISTEN      12078/sshd      


[root@vs home]# which pure-ftpd
/usr/bin/which: no pure-ftpd in (/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin)

Basically, I wish to either fully remove it as I'm trying to keep my CentOS running without packages that I don't need. Or make it run, but make it run with a virtual user that I need with chroot access to /home directory.

share|improve this question
    
Oh, I've used ./configure && make install-strip to install it and then ./configure uninstall to remove it from the directory I've installed it. –  Max Mar 2 '11 at 11:59

1 Answer 1

up vote 1 down vote accepted

Looks like the process is still running. Try killing it:

kill 11359

or

pkill pure-ftpd
share|improve this answer
    
It did the trick. I suppose ftp will be disabled for good now. Thank you @ Cakemox –  Max Mar 2 '11 at 12:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.