Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I started installing Windows XP Pro SP3 this morning via WSUS. The first machines seemed to patch OK apart from one problem.

The autocomplete and autosuggest on the Run Menu and Explorer address bar have stopped working.

The urls in the typed history are still there if the drop-down is clicked but they don't appear as you type. File paths are not prompted either.

The autocomplete works fine in IE 7 and in file dialogs.

The suggestions I've found so far all seem in order:

  • The options to use autocomplete are checked in Internet Options | Content | AutoComplete | Settings
  • 'Use inline AutoComplete' is checked in Internet Options | Advanced | Browsing
  • TweakUI has 'Enable AutoComplete' checked in the Common Dialogs options.

Registry:

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\AutoComplete]
"Append Completion"="yes"
"Use AutoComplete"="yes"
"AutoSuggest"="yes"
"AutoComplete In File Dialog"=dword:00000001

What can be causing this?

UPDATE: Autocomplete has started working again on the affected machines, so it must have been fixed by patches applied in the last couple of weeks.

Has anyone else experienced this?

share|improve this question

2 Answers 2

Try this solution. I was able to successfully disable and re-enable my autocomplete for the run dialog with the other settings being present.

  1. Open Internet Explorer

  2. Click Tools, Internet Options

  3. Select the Content tab

  4. Under AutoComplete, click Settings

  5. Place a checkmark near Web addresses

  6. Click OK, OK.

This enables the AutoComplete drop-down feature to the Run dialog.

share|improve this answer
    
That certainly works on my own XP machines. I'm able to disable and re-enable Run Menu autocompletion toggling the Web Addresses checkbox as you suggest. I'll try it on the machines in the office tomorrow and report back. Many thanks in the meantime! –  Jonathan Webb Jun 11 '09 at 20:49
    
This doesn't work on machines patched to SP3; they still don't autocomplete. Toggling the Web Addresses checkbox on SP2 machines works fine. I'm comparing behaviours with RegMon but nothing obvious yet.. –  Jonathan Webb Jun 12 '09 at 9:28
    
My machine runs SP3 and it works as I described. –  Jack B Nimble Jun 12 '09 at 14:54
    
My own machines run SP3 and work just fine as well. Perhaps it's a combination of recent patches causing this.. Thanks for your help Jack :-) –  Jonathan Webb Jun 12 '09 at 15:28

I happen to have the same issue I did a search in registry for "autocomplete" keyword.

found this location as the possible issue

[HKEY_USERS\<user>\Software\Microsoft\Windows\CurrentVersion\Explorer\AutoComplete]
"Append Completion"="no"

I just updated the following key from "no" to "yes"

Please note to change the to the windows user name.

The change worked fine ;)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.