Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i have just installed apache2 on my ubuntu shell,..but when i'm trying to test apache on my server with a command

http://localhost/apache2-default/

it's showing server not found...

what should i do???

need help!!!

share|improve this question

migrated from stackoverflow.com Mar 2 '11 at 14:00

This question came from our site for professional and enthusiast programmers.

    
Stack Overflow is about programming. Maybe you wanted to post this on Server Fault? –  Delan Azabani Mar 2 '11 at 11:10
    
How exactly did you install apache? What do you get when you visit http://localhost/? –  Karpie Mar 2 '11 at 11:11

4 Answers 4

hey that one is working now....but starting the apache is giving an error

Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName

i thought that i need to make change to httpd.conf file ,...but i'm not able to do so ...

can someone explain how to do that

share|improve this answer

did you start the server by using 'apachectl' command? assuming you did, go to the shell and type,

ps -ef | grep httpd

If you can see a process named 'httpd' running then the installation works. And there might be some error in the url you are using.

share|improve this answer

You can check if apache is running by writing

ps aux | grep apache

in your shell.

If apache is not running you can start it with either

apache2ctl start

or

/etc/init.d/apache2 start
share|improve this answer

Try sudo /etc/init.d/apache2 in the termainal to start apache

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.