Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just rebooted an Ubuntu Server 10.04. After choosing boot options in the grub menu, though, it just displays a black screen with the blinking white underscore in the upper-left corner.

The machine has had (hardware) trouble with networking before, but the problem remains after 10 minutes, so I don't think it's the problem now. Booting into recovery mode or using earlier kernels yields the same problem. This also happens if I boot from another hard-drive.

I haven't yet tried to boot from CD as the machine lacks a CD reader.

How should I diagnose the problem?

Update: My boot options are:

recordfail
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set 567[redacted]
linux /boot/vmlinuz-2.6.32-29-generic root=UUID=567[redacted] ro quiet splash
initrd /boot/initrd.img-2.6.32-29-generic

Update: Also, I cannot access the virtual terminals (ctrl+alt+Fn).

share|improve this question
add comment

1 Answer

Try editing the selected option ('e') going to the 'kernel' line and removing the 'quiet' and 'splash' options from the end if they are there, then continue the boot and see if you get a few more diagnostics to help you.

share|improve this answer
    
I tried to remove them, but the same thing happens. No additional information. I updated my post with the full boot options according to grub. –  user68912 Mar 2 '11 at 14:43
    
Bah, how evil. Trying my best to give other solutions than to reinstall grub2/grub... I see bugs.launchpad.net/ubuntu/+source/grub2/+bug/499220/comments/2 has a solution to this problem, when it was caused by a faulty clock. Perhaps try adding those two boot parameters "clocksource=hpet" and "notsc" to the kernel line and see if that works? If so, I'll update my answer above with the permanent solution. –  PriceChild Mar 2 '11 at 15:52
    
Hmm... googling "clocksource=hpet" shows quite a lot of people with 'similar' issues being solved with this. I'm hopeful! –  PriceChild Mar 2 '11 at 15:53
    
This unfortunately did not change anything, either. –  user68912 Mar 2 '11 at 19:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.