Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using a Dell PowerEdge 2900 running RedHat 5. I had 4 drives in the system using RAID 5; I purchased and installed 4 more drives keeping the configuration the same. Set up the Virtual disks in PERC 6/i. When I exit out and reboot the system I get the following:

fsck.ext3: No such file or dirrectory while trying open /dev/sdb1 [FAILED]

***An error occurred during the file system check.
***Dropping you to a shell; the system will reboot
***when you leave the shell.

Then am prompted for the root pw. I enter it and am then prompted with:

(Repair filesystem) 1#

if I type fdisk -l I get some info on the disk along with:

Disk /dev/sdb doesn't contain a valid partition table

I am then prompted for

(Repair filesystem) 2#

If I reboot I am taken to the same screen again. The system was working before this happened. Does anyone know why this is happening and or what I can do to fix it? Thanks

share|improve this question

1 Answer 1

There are parts of your question that aren't particularly clear:

I purchased and installed 4 more drives keeping the configuration the same...

You added additional drives? Or you replaced the four drives that were there?

Set up the Virtual disks in PERC 6/i.

As a new RAID volume? As an expansion of an existing RAID volume? As something else?

if I type fdisk -l I get some info on the disk along with:

Does fdisk -l show just a single drive? Are you expecting to see more?

Absent answers to those questions, here's a wild guess:

What does your /etc/fstab file look like? If you are referencing block devices as /dev/sdb1, you have a fragile configuration -- adding new disks can cause the drives to be scanned in a new order, such that what used to be sdb may now be sdd or something else. This is why your fstab should really only reference devices by UUID, by label, or as logical volumes.

If this was your problem, though, fdisk -l would still show what used to be /dev/sdb, just under a different name. So I expect that your problem is probably something else.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.