Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I try to install this module via cpan: cpan -i Apache::Template

I get an error "512, won't make". This behavior is the same on Debian Lenny or Squeeze.

Any ideas on how to get it to build?

share|improve this question
add comment

2 Answers

First install Apache::ModuleConfig:

 cpan -i Apache::ModuleConfig
share|improve this answer
    
Warning: Cannot install Apache::ModuleConfig, don't know what it is. –  Bobber Mar 2 '11 at 17:55
add comment

It seems that these versions of Debian use mod_perl 2. The version of Apache::Template on CPAN only works with mod_perl version 1. You can get a version that works from http://www.modperlcookbook.org/~geoff/modules/experimental/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.