Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to work out how to use SQL server management studio properly with multi-byte unicode characters. even something as simple as:

select N'动漫'

just returns square boxes in the result pane. I know the underlying database is set up correctly to handle unicode and other apps on the PC work fine with chinese characters

any clues very much appreciated

share|improve this question
up vote 2 down vote accepted

I believe you can change the fonts used for results somewhere in the options. You may need to choose a font with the appropriate Unicode glyphs.

Edit: Just to elaborate a bit since I'm actually in front of my computer now, go to Tools, Options, then navigate to Environment, Fonts and Colors. Pick Grid Results from the menu, and select an appropriate font.

share|improve this answer
I use Consolas for text results, and I get the correct glyphs showing (2008 Management Studio running on Win7). NB this result will also depend on font fallback and level of OS internationalisation (which has improved steadily with newer versions of Windows -- according to Character Map Consolas doesn't contain those glyphs. – Richard Mar 3 '11 at 9:56

As db2 suggested, you probably need to choose a font with the right glyphs.

Tools -> Options

Environment -> Fonts and Colors

share|improve this answer

After many frustrating hours with this problem, I just discovered a solution (if not an explanation).

Changing the Query Results font had no effect on my system (Win 7 Enterprise, 64-bit).

After much Googling I discovered this: My Chinese Word Suddenly Appear As Square Box

In short: create a new Windows user account, then log in as that user - you should find that your Chinese characters display correctly. Now log in to your original account, and you should find this also now displays Chinese characters correctly.

So creating the new account has the effect of fixing the behaviour for both (possibly all?) accounts. Now - anyone have an explanation?

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.