Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm sure I'm doing something wrong. I'm expecting my current rules of "denying all incoming/outgoing" to cripple anything network related, but it's not.

First, I did:

sudo ufw default deny incoming

sudo ufw default deny outgoing

And then I checked it:

sudo ufw status verbose
Status: active
Logging: on (low)
Default: deny (incoming), deny (outgoing)
New profiles: skip

Looks good, and then I reloaded it:

sudo ufw enable

sudo ufw reload

sudo service ufw restart

Yet, I'm able to post this on the interweb and do everything else.

share|improve this question

closed as off-topic by womble, Michael Hampton Aug 14 '15 at 2:21

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

1  
What does ufw show raw say? According to the manpage, status doesn't show "hardcoded" rules from /etc/ufw so you may have some defaults configured there. – DerfK Mar 3 '11 at 0:49