Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have an instance of Atlassian Confluence fronted by Apache using mod_proxy_ajp to pass inbound port 80 requests to 8080 on tomcat. Let's say the url users use is http://www.mywiki.com/confluence/. Confluence generates emails to send to users with links to pages with changes. When a user clicks on links in those emails, the user is taken directly to the local server hostname with :8080, not the public facing DNS name that Apache accepts requests from.

In other words, the links are http://nasty-app-server-name:8080/confluence/xyz/ and not http://www.mywiki.com/confluence/xyz.

How can I configure Confluence to insert www.mywiki.com in the hyperlinks generated by Confluence, instead of the nasty-app-server-name? I figure somewhere there's a template that has $hostname. I want to override that with a DNS name.

share|improve this question
    
And I found the answer myself. The setting to change this is "Server Base Url" under General Settings in the Admin left menu. –  ed209 Mar 3 '11 at 19:46
1  
+1 for posting the answer, although it's better if you post an actual answer and accept it - that way this question won't come up in the unanswered list. –  gareth_bowles May 18 '11 at 21:39

1 Answer 1

up vote 1 down vote accepted

And I found the answer myself. The setting to change this is "Server Base Url" under General Settings in the Admin left menu.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.