Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

So I have to confess that I'm not a network admin so my knowledge of DNS is very limited, and I think I've screwed something up.

I own a domain--let's call it mydomain.com. I had my hosting provider set it up so that gordon@mydomain.com forwards to soapergem@gmail.com (my Gmail account). This seemed to be working fine; when I would send an email to gordon@mydomain.com I would receive it in my Gmail inbox, and when friends would send to that address I would likewise receive it. When we originally set that up (and when it was working), I don't believe we had any MX records for mydomain.com at all.

A little later I started using an email sending service. (Something along the lines of MailChimp, although it was not MailChimp.) Let's call it mysender.com. I noticed that anytime I would try to send to gordon@mydomain.com using MySender, it wouldn't work. It would never go through. Using that service, sending to anybody else from gordon@mydomain.com worked perfectly! But when I tried to send mail from gordon@mydomain.com to gordon@mydomain.com using that same service, it would never come through.

So I started doing a little digging trying to find out why that was, and one site I found suggested that I needed to set up MX records for the domain in the DNS. So I just did that yesterday, and now I'm afraid that I screwed things up, as no mail at all seems to be flowing through anymore. Now even when I send to gordon@mydomain.com from Hotmail or something like that, it no longer shows up in my Gmail inbox.

These are the records I added. Can someone tell me what I did wrong, and what I need to do differently?

mydomain.com MX 3600 [10] mydomain.com
mydomain.com MX 3600 [20] smtp2.mysender.com
mydomain.com MX 3600 [30] inbound.mysender.com
share|improve this question
    
Can I ask what you're trying to accomplish with your mail? –  gravyface Mar 3 '11 at 13:35
1  
The only thing that was wrong (if I read your post correctly) before you changed MX records, was that you were unable to send mail to yourself. Is that correct? If so, revert your MX record changes, and investigate the Outbound Mail Server settings in your email client. –  JeffG Mar 3 '11 at 13:46

4 Answers 4

up vote 3 down vote accepted

If mysender.com is only sending mail and not receiving it, it should not have any mx records on your domain. (Delete the 20 & 30 MX records). Additionally, mydomain.com referenced in your mx record MUST HAVE AN A Record, a cname record will cause problems with mail delivery. Finally, if the other users in your domain do not receive mail from mydomain.com, they must have forwards or aliases set up om mydomain.com.

share|improve this answer
2  
you might also want to check at mysender.com to see what they do with mail addressed to you. Since they are sending mail for you, it is quite possible that they are attempting to deliver mail for your domain from their own smptp server without even consulting mx records. –  Scott Mar 3 '11 at 15:45
    
This helped a lot. I deleted the 20 & 30 records, and then contacted my web host, and apparently they had an issue with the SMTP relay that was forwarding mail to my Gmail account. –  SoaperGEM Mar 4 '11 at 2:50

You should only be publishing MX records for the MTA you want mail sent to. And in addition to the MX to hostname record you also need an address record for the host.

You don't add MX records for hosts you send mail from.

You should however publish SPF records - which include all the hosts/domains you send mail from

share|improve this answer
    
Ok, so should I just delete the priority 20 and 30 MX records then? And I already do have an SPF record set up, but thanks for the tip. =) –  SoaperGEM Mar 3 '11 at 14:08

Have you considered setting up Google Apps for your domain?http://www.google.com/apps/intl/en/group/index.html

It'll guide you through the process and it might be a bit more solid than what you've got.

share|improve this answer
4  
That's a cop out answer if I ever saw one. =P The question was about MX records. –  SoaperGEM Mar 3 '11 at 14:40

In any case, it seems like you need a final dot "." at the end of you MX records, whatever the previous advice may be:

  • mydomain.com MX 3600 [10] mydomain.com.
  • mydomain.com MX 3600 [20] smtp2.mysender.com.
  • mydomain.com MX 3600 [30] inbound.mysender.com.
share|improve this answer
    
Correct, you do; it indicates that the name is an FQDN. –  Falcon Momot Sep 17 '13 at 5:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.