Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

after installing monit when i do monit status myproc i get "error connecting to the monit daemon"

I read somewhere that

The status command won't work in the case that monit is running indaemon mode without its http support - the command 'monit status' in such case tries to get the status from the daemon via http/tcp. To start the http interface you need to add the 'set httpd ...' statement to theconfiguration.

is that still correct? that post was from 2005

share|improve this question

5 Answers 5

up vote 5 down vote accepted

I was struggling to setup monit on my ubuntu server and here are a few things to check:

  • Make sure that you set startup=1 in /etc/default/monit
  • Make sure to un-comment the httpd parameters in /etc/monit/monitrc

One last "gotcha" in /etc/monit/monitrc:

set daemon  120           # check services at 2-minute intervals
#  with start delay 240  # optional: delay the first check by 4-minutes (by
#                           # default Monit check immediately after Monit start)

I had the "with start delay 240" line un-commented at first. It appears that the httpd server will not start immediately if you use this option. It took me awhile to realize why monit was running but the httpd server was not.

share|improve this answer
    
Note - the http parameters must be uncommented even to view a summary from the command line using i.e. sudo monit summary –  Troy Feb 12 '13 at 5:35
    
@Josh: Thanks man! –  Manoj2411 Nov 18 '13 at 6:34
 set httpd port 2812 and
  use address 0.0.0.0
  allow 0.0.0.0/0.0.0.0
  allow admin:monit

I think this is better,it will add a web page to see the monit result,and the user name and password is admin and monit.

share|improve this answer

I'v added this lines my conf file

set httpd port 2812 and
use address localhost
allow localhost
share|improve this answer

Make sure you have enabled the HTTP daemon and added allow localhost. There's a write up on how to correctly configure monit to avoid this error here.

share|improve this answer

In order to make this work, you have to set the monit httpd process to allow connections from localhost.

In your config file, you should uncomment the line that says allow localhost and restart monit.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.