Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Windows Server 2008 R2 machine connected to an IPv4 Windows network that cannot resolve the simple name of another server when trying to access a file share. If I try to browse to \\SERVERNAME in Explorer I get

The network name cannot be found

However, other server names (from the same domain) work fine. I can also connect to the same server if I specify the FQDN, ie. \\SERVERNAME.my.domain.com Pinging the simple name (ping SERVERNAME) also works. Does anyone know what's wrong here?

share|improve this question
    
Was this ever resolved? –  Lockszmith Mar 25 at 17:49

1 Answer 1

Since it resolves with the FQDN, it sounds like DNS is working, but your DNS search suffix may not be configured, causing the single name to be failing to resolve?

The single names for other servers may be resolving via netbios/WINS, but the server that's not resolving may not be registering.

Check your DNS search suffix list, and test netbios with nbtstat -a servername

Edit: just realized that ping works with the single name. Check the nbtstat, and if that fails to find the name, try disabling netbios altogether in the network adapter settings.

share|improve this answer
    
nbtstat -a servername worked OK and showed the MAC address. I ended up rebooting that machine and now it works. Weird. Thanks for your help anyway, +1. –  EMP Mar 4 '11 at 4:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.