Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a user that cannot authenticate. What I am getting is:

did not issue MAIL/EXPN/VRFY/ETRN during connection to MTA

I have SASL installed for plaintext passwords. Can someone please point me in the right direction? What am I missing?

share|improve this question
    
1. The error message does not have anything to do with authentication. 2. Neither does TLS (if you are using SASL for auth). –  grawity Mar 4 '11 at 6:21

1 Answer 1

The error message means that the client opens up a connection to port 25 on your server, but does not issue any other commands. I will make a wild guess here and will suspect that this is a TCP window scaling problem. If the client is a Windows Vista / 7 machine try something like:

netsh interface tcp set global autotuninglevel=disabled

or

netsh interface tcp set global autotuninglevel=restricted

from a command prompt that you have started as an administrator. If your server is a linux machine you can try adding these at the bootom of your /etc/sysctl.conf:

 net.ipv4.tcp_rmem = 4096 87380 174760
 net.ipv4.tcp_wmem = 4096 16384 131072
 net.ipv4.tcp_window_scaling = 0

Run "sysctl -p" as root for the changes to take effect. Depending the case you may need both. However this is a workaround and not a solution to the problem, and like I said a wild guess since I've seen such behaviour coupled with the error message that you describe too many times.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.