Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We had an old CNC machine's hard-drive fail recently. The hard-drive is an old 1275MB IDE (Seagate) and there were defiantly bad sectors on it. I was able to image the contents of the drive onto a drive in my computer before it became completely unusable (I used DD, replacing all bad sectors w/ 0s). After running a couple chdsks, the SATA drive will boot off of the image. This is great, but there's one problem. The CNC machine old and requires IDE, I've attempted to copy the currently booting image off of the SATA drive and onto IDE drives numerous times in numerous ways and every time I do so the machines return that a boot device cannot be found.

Some other information:

The file system is fat32, running windows 98  
The SATA drive is an 80gb drive
I have tried copying the image to three 20gb and two 80gb IDE drives  
I have checked the jumper on the back of the IDE drives when using them

If anyone has any ideas, questions, suggestions, etc. please let me know.

P.S. I would just put a fresh install of win98 on the machine if i had the installation media (so that's out of the question). And if it comes to it, this is my last week working here, so I'll leave that to my co-worker.

EDIT: Also, I have tried using Clonezilla as well as straight up DD to copy the image to the IDE drives.

share|improve this question
Does the machine's BIOS report that it's seeing the new IDE drives? Is it a BIOS boot error or something else? Have you contacted the manufacturer to see what drive size the machine will support; some machines will simply report no disk at all if it's "too big" (if that's the case, a DMA capable CF Card with an adapter might work). – Chris S Mar 4 '11 at 14:53
In each case, yes. – Ormis Mar 4 '11 at 14:54
I'll give you a more complete answer to your questions: The BIOS does see the devices. It is the "insert boot drive to continue" from the bios. The manufacturer is no longer available for the machine. I'm attempting to do this on a device other than the one that it is meant for. Also, as I said before, the 80gb SATA drive does boot... the other don't, so the size cannot be the issue. – Ormis Mar 4 '11 at 15:05

If you used /dev/hdax (where x is an integer) as the if= argument to dd then you copied a partition (volume) as opposed to the entire drive. In either case, it sounds like you might just need to enable the boot flag on the partition using fdisk.

share|improve this answer
I'm fairly certain that the boot flag is on the partition... i'll make sure soon. – Ormis Mar 4 '11 at 15:02
The boot flag is enabled on the partition. – Ormis Mar 4 '11 at 15:14
This may be a dumb "did you plug it in?" kind of question, so please forgive me. Is the motherboard BIOS configured to boot this disk first in the disk boot order? – JeffG Mar 4 '11 at 15:20
I'm more than happy to answer those questions (i hope it's something stupid i forgot...), but yes, the IDE drives were selected as the boot device when testing them. – Ormis Mar 4 '11 at 15:25
Perhaps the old hard drive in the CNC machine didn't fail? Perhaps the PATA Hard Drive Controller did? Can it read ANY PATA drives? – JeffG Mar 4 '11 at 15:28

Check the Hard Disk controller in the old system to make sure the problem isn't there.

share|improve this answer
I'm testing the newly written pata drives in other machines. I've tried them in my workstation and a few others, all of which I know have working controllers, but all return the same results. – Ormis Mar 4 '11 at 15:45

The tool can boot or repair the new disk also. Make sure your restored partition is the first primary, as small as the original one. You can check this with GParted from clonezilla, or PMagic boot CD. They also have a boot option for supergrub disk. Make sure the MBR type is set to DOS.

If the new IDE drive is not to large for the BIOS to 'see' try to boot from a floppy disk. Try the Win98 image disk from and access the hard disk. A simple fdisk /mbr may be all it needs.

Long shot: What is your cnc machine BIOS date? If very old it may not recognize larger IDE disks. The disk company may have an 'overlay' util that makes the disk load and fake out the bios.

Good luck on the new job! Let us and your replacement know how this works out!

share|improve this answer
Super GRUB2 Disk can also see what the ide disk looks like on the cnc box. Check this overview for details – BarnAgain Mar 4 '11 at 17:23

One other option may be to go with a hardware solution. There are devices that let you to connect a SATA drive to an PATA (IDE) port. If that will let you see the SATA drive from the CNC machine you might be able to boot from it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.