Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Last week I decided to use TeamViewer VPN to administer software on a server behind a firewall using RemoteDesktop. It was easy to configure to start-up with the system and make VPN available on the other side but now it fails to connect at the step shown below:

TeamViewer failing to connect

The remote machine is running Windows Server 2008 R2.

Is there a native way to circumvent the external firewall using a server role or feature to make Windows Server do the VPN work?

Do people have better / more reliable experiences with other products such as Hamachi?

The requirements are as follows:

  1. Start at remote system start-up time
  2. Make VPN connections to the remote machine possible
share|improve this question

2 Answers 2

TeamViewer does not need to have open port. By default it's connecting via TeamViewer HQ's servers and delivers you instant connection without any network configuration. Of course there is option to connect directly on LAN (hidden somewhere in advanced settings). For unattended connections you can set up static password and connect to machine only by providing it's ID & pass. If my knowledge is up to date you can do the same with VPN connection. It staarts at boot up.

share|improve this answer
    
Maybe he has a very locked down firewall with a l7 filter checking that port 80 is actually HTTP! –  Matt Nov 13 '12 at 1:28

By default TeamViewer uses only the outgoing port 80 - no firewall configuration is usually necessary, however you can open port 5938 which I've found to be necessary on some firewalls. I'm assuming the problem is when you try to connect to a server through TeamViewer and you're not even getting to the RDP part?

share|improve this answer
1  
I cannot open ports in that firewall as it is administered by another department. Next week I will go and try to configure DirectAccess and other solutions on that machine. –  Cetin Sert Mar 5 '11 at 3:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.