Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have the following in my OpenLDAP configuration. Using the latest version OpenLDAP on Centos 5.3. Installed using yum.

From my /etc/openldap/slapd.conf

database        bdb
suffix          "dc=company,dc=com"
rootdn          "cn=Manager,dc=company,dc=com"

From my /etc/openldap/ldap.conf

BASE dc=company,dc=com

I have successfully added an entry with ldapadd and retrieved it with ldapsearch from a local bash shell on the box.

Now I am trying to get a Graphical Editor to connect to this server remotely so I can enter people from my laptop. But I am having no luck. I tried JXplorer, and it connects with Anonymous bind without me having to specify a BaseDN but I can't edit anything that way.

If I try and give it a user name and password, using Manager and my rootpw I have in clear text just for testing, every GUI Client on my remote laptop complains about my BaseDN not being the correct format when I enter dc=company,dc=com and I tried cn=Manager,dc=company,dc=com.

Error opening connection:
[LDAP: error code 34 - invalid DN]

I have tried multiple clients and all of them connect as anonymous, none let me connect authenticated where I can actually create or edit anything.

I am using Manager as my username and the password from rootpw, is that correct?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I figured it out, I needed to give a fully qualified User DN for the user cn=Manager,dc=company,dc=com I was just putting Manager in.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.