Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When I'm trying to connect to MSSQL I get error that there is nothing running on the port 1966.

when I look at processes I see 3 named sqlserver.exe, but when I see the PID's understand .. they are not there. so they are not using any ports. How to force SQL Server to run on port 1966?

P.S. I'm using C# when trying to connect to the database.

share|improve this question

migrated from stackoverflow.com Mar 6 '11 at 18:12

This question came from our site for professional and enthusiast programmers.

    
sql-server-performance.com/faq/… –  malinois Mar 6 '11 at 18:05
    
@IAdapter - It's a configuration issue so belongs on ServerFault. –  Martin Smith Mar 6 '11 at 18:07
    
@Martin thx for clarification –  10. Mar 6 '11 at 18:07
    
@malinois the problem is that its not running on any port, any ideas? –  10. Mar 6 '11 at 18:12

2 Answers 2

  1. Open "SQL Server Configuration Manager"
  2. Expand the "SQL Server 2005 Network COnfiguration" tree
  3. Select "Protocols for MSSQLSERVER"
  4. Right click TCP/IP
  5. Open the "IP Addresses" tab
  6. Under "IPAll", change the value for "TCP Port" from 1433 to 1966
share|improve this answer

Why are you trying to connect to SQL Server on port 1966? It's normally running on port 1433.

The PID that you see for services is a Process IDentity, it has nothing at all to do with port numbers.

If you really want to change the port number that the database server is listening on, you do that in the settings for the database. For example outlined in this article.

share|improve this answer
    
its not running on any port. I thought it was 1966 by default. How to make it run on 1433? –  10. Mar 6 '11 at 18:10
    
@IAdapter You need to enable TCP/IP protocol then it will start listening on a port. Do you have 3 instances installed? If so you will probably want to make sure that the SQL Browser service is running as they can't all listen on 1433. –  Martin Smith Mar 6 '11 at 18:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.