Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Installing NPS results in the error below:

attempt to install network policy server failed with error code 0x80070643 fatal error during installation

The SBS server ran an update on Friday and since then, NPS has not worked. I have checked permissions on system32\IAS and the builtin OU, but still cannot run NPS. My last attempt to remove and reinstall has now left the machine unable to install NPS at all!

Has anyone seen this or have a direction to suggest? Google has shown other people haven't been able to resolve it.

The server manager log shows the below:

[CbsUIHandler] Error: -2147023293 : 2011-03-08 09:41:20.515 
[CbsUIHandler] Terminate: 2011-03-08 09:41:20.515 
[CBS] Error (Id=0) Function: 'NativeMethods.GetPackageStatus(out status)' 80070643 (-2147023293) 2011-03-08 09:41:20.515
[CBS] ...done installing 'IAS NT Service '. Status: -2147023293 (80070643) 2011-03-08 09:41:20.515
[InstallationProgressPage] Verifying installation... 2011-03-08 09:41:20.546 
[Provider] Skipped configuration of 'NetworkPolicyServer' because install operation failed.
share|improve this question

3 Answers 3

I was able to resolve this issue by executing "sfc.exe /scannow"

share|improve this answer
    
Please give a bit more details. Any downsides? –  vonbrand Mar 1 '13 at 3:15

Have you tried the resolutions suggested by Microsoft in KB958052?

If that doesn't work, you could try to remove every .NET-installation on the server and then clean it up with the .NET Framework CleanUp Tool. Afterwards, try reinstalling them if you need them and run the updates again.

share|improve this answer
    
Thanks, I tried that, it got slightly upset when .Net was cleared up. Although I don't think its a framework issue I thought it was worth a try! I looked at the servermanager log and got this snippet –  Anthony Wray Mar 8 '11 at 9:55
  1. Check the value for NT AUTHORITY\NETWORK SERVICE Reg_Word key under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VSS\VssAccessControl

    If this is set to 0 change the value to 1.

  2. Stop “World Wide Web Publishing Service (W3SVC)”
  3. Remove (save in Temp folder) all files from Windows\System32\ias folder
  4. Copy from a good Windows 2008 R2 machine the dnary.xsd file
  5. Install Network Policy Server role
  6. Restart the server.

From: http://blog.montarel.com/tech/2013/10/nps-install-failed-with-error-code-0x80070643/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.