Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am hosting a Merak e-mail server for our domain example.com. Everything works great accessing the server from outside the network using mail.example.com for ingoing and outgoing servers. However, clients on the same LAN as the mail server get the error "Outlook cannot connect to your outgoing (SMTP) server"

I have to set the Outgoing server to the internal DNS name or internal IP address of the mail server. This really sucks for our laptop users that move in and out of our network. My question is how can I fix this? Users are able to access webmail using mail.example.com even when in the network so I am thinking this is a setting in merak somewhere.

share|improve this question
    
are you able to setup mail.example.com on the internal DNS server to point to the internal host? –  pablo Mar 7 '11 at 16:52
    
I probably could do that but that seems like it doesn't fix the core problem. Also, wouldn't computers that are using external DNS servers still have the issue? –  Jason Mar 7 '11 at 16:58
    
When they're inside the network, they'll need to use inside DNS - no good way around that part. –  Shane Madden Mar 7 '11 at 17:37

2 Answers 2

up vote 0 down vote accepted

I'm assuming that you're behind NAT, and if so it sounds like your problem is with Hairpin NAT; your router is port-forwarding traffic on port 25 only if it originates on the external interface (which is why it works for external clients). You'll need to either change a setting on your router to allow forwarding traffic that arrives on the internal interface, or try a different router, or set up internal DNS.

share|improve this answer
    
I am behind a NAT. I probably should of mentioned that. Would this still be the problem if internal users can get to webmail using mail.example.com/webmail? Also, it seems POP3 works with mail.example.com for internal users as well. It's just SMTP that fails. I'm looking at router config now. –  Jason Mar 8 '11 at 14:50
    
I still haven't found the problem but thank you for introducing me to the hairpin NAT! –  Jason Mar 8 '11 at 22:05

Set all your systems' email clients' outbound SMTP server to mail.example.com.

If they cannot connect, then check your firewall for a block on port 25 (outbound). This port is commonly blocked in firewalls to prevent rogue applications from sending mail, however, if this is set, you'll need to make an exception to allow outbound mail to your server only. http://kb.siteground.com/article/How_to_check_whether_SMTP_port_25_is_blocked.html

When all users use the same, externally routable address, then it won't suck (or at least will suck less) for your laptop users.

Make sure that mail.example.com on your LAN resolves to the external IP address of the mail server.

It is unlikely that the problem is with your mail server settings.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.