Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am able to connect to Exchange via mobile devices, and OWA, but setting up Outlook clients internally I receive "the action cannot be completed, unable to connect to exchange...."

I've edited the host file for IPv6 loopback issue to no resolve. In a two part question, where do I start to troubleshott his, and do internal clients automatically setup using RCP over HTTP? Or do they setup with FQDN, or the remote DNS HTTPS address?

share|improve this question
    
DNS resolves fine internally by the way...And can also telnet to 6004 –  Seth Mar 7 '11 at 16:59
    
I was able to finally connect, after manually having to set it up through the external DNS name. If I used localname.fqdn.com it is unable to connect. (fqdn not in cert maybe?) My logic tells me internal clients should be using the FQDN before the external address... –  Seth Mar 7 '11 at 17:18
add comment

2 Answers

Chances are, your auto-discover settings are off. Outlook clients use auto discover to find the exchange servers and if those names are not on the certificates problems can result. Local clients will be using mapi or, maybe even rpc over http if discovery doesn go well. Exchange does have settings for internal and external autodiscovery urls.

share|improve this answer
    
Well Autodiscovery is on, when I add a profile, it detects the user (not quite correctly, name format not right) none-the-less it is active. Do you know how I can check if FQDN is correct in cert? –  Seth Mar 7 '11 at 18:50
    
scratch, did an Get-ExchangeCertificate |fl I may have missed the FQDn in the cert. because it's not listed, just has mail.domain.cm and autodiscover.domain.cm could this be the culprit? –  Seth Mar 7 '11 at 18:53
add comment
up vote 0 down vote accepted

Need to add the FQDN of the server to the SSL certificate.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.