Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Whenever I join a network where there are other Macs, I sometimes get the notification:

This computer's local hostname Macintosh.local is already in use on this network. The name has been changed to 'Macintosh-2.local`.

From then on the result of hostname is this changed name. I've tried:

  • System Preferences->Sharing->Computer Name.
  • sudo hostname jared-mac.
  • Modified /etc/hostname.
  • System Preferences->Network->Advanced... ->TCP/IP DHCP Client ID
  • System Preferences->Network->Advanced... ->WINS

Is this a known issue? Or am I doing something wrong?

share|improve this question
    
    
    
    
I actually have encountered the same issue a few times, using a very unique computer name... (I did not try to disable IPV6 like suggested in one of the links above, as it does not really bother me.) –  Arjan Jul 11 '09 at 20:08
add comment

2 Answers

up vote 4 down vote accepted

Normally the two are in sync, but you can alter the hostname by going to:

System Preferences -> Sharing -> Under Computer Name on the right side is an Edit button. Click the Edit button and in the new sheet alter your hostname to match your computer name.

share|improve this answer
1  
So when your hostname is "jared-mac" it is reverting to "Macintosh-#" - even if the hostname of the other Mac is not the same? –  Chealion Jun 12 '09 at 5:49
    
@Chealion, you are right. You have to press the Edit button which presents a dialog where a completely different value (Macintosh-#.local) is stored. –  Jared Oberhaus Jun 12 '09 at 17:52
    
@Jared - Sorry I should have made that more clear. Edited the answer. –  Chealion Jun 12 '09 at 18:31
add comment

System Preferences - Sharing - Computer Name

share|improve this answer
2  
Did you try pressing the Edit... button underneath it? Occasionally the Computer Name and Hostname don't match requiring you to adjust it there as well. –  Chealion Jun 11 '09 at 23:57
    
@sweimann, you are almost there. The Edit button next to Computer Name is misleading--it's for editing the local name, not the Computer Name. –  Jared Oberhaus Jun 12 '09 at 17:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.