Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I want to use WMI on Windows XP to manage an IIS 6.0 server. I have installed the IIS 6.0 Manager but the WMI components still aren't available.

I'm using the following line of PowerShell to test whether the WMI components I need are installed. This works fine on my Windows 7 machine with IIS 6 WMI Compatability installed, as well as on a Windows 2003 server with IIS 6 installed.

[wmiclass] 'root/MicrosoftIISv2:IIsWebServer'

What do I need to install on Windows XP for this to work?

share|improve this question

1 Answer 1

The IISv2 is only supported in IIS7 and greater. For XP you'll need to use the original WMI provider unfortunately. It installs with IIS, so it's there already. The older provider is still good, but it's the version behind the version you're using on your Windows 7 machine and is missing lots of the new features.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.