Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I tried to setup apache 2.2 in amazon aws using amazon ami. i did installed httpd and php and congirue http.conf to use /var/www/html.

Then put file index.html on that folder. But when i tried to use browser to browse my domain which is ec2-122-248-255-181.ap-southeast-1.compute.amazonaws.com, nothing was loaded.

I did start httpd by running apachectl start, and i can see it listening on port 80.

Does anybody know what is wrong?

share|improve this question

3 Answers 3

up vote 3 down vote accepted

Check that you are allowing traffic on port 80 in your EC2 security group.

Go to your EC2 dashboard and click on Security Groups. Select the Security Group that is attached to your instance. Check that there is a line that says

HTTP        tcp        80       80        0.0.0.0/0

If it exists then your problem lies elsewhere otherwise add the line using the select boxes.

share|improve this answer
    
Yeah, you rock. –  hudarsono Mar 9 '11 at 4:23

Can you connect locally? SSH into the instance and try to telnet 127.0.0.1 80.

If you can't, check for a firewall locally on the machine. Check the system logs, and the apache error logs.

If you can, check your Security Group in EC2 and make sure port 80 is allowed.

share|improve this answer

Check the permissions of your html files as well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.