Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using WHM. I want to set the default behaviour for any created accounts to be No-Indexing.

Also, when an account accesses CPanel, I want it to be shown the HTTP prompt for user and password instead of the HTML form.

How can I do that please?

share|improve this question

closed as off-topic by Iain, kasperd, Ward, Jenny D, MadHatter Feb 23 at 15:21

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

up vote 1 down vote accepted

For the first part of your question

To disable indexing globally, go to:

Main >> Service Configuration >> Apache Configuration >> Global Configuration

And then you can deselect indexing and save and rebuild conf to disable it by default, alternatively you can create a skeleton .htaccess file in /root/cpanel3-skel which the line

Options -Indexes

For the second part, the setting is in the security section of tweak settings in WHM: Main >> Server Configuration >> Tweak Settings

Enable HTTP Authentication

However for security I would not recommend making this change

share|improve this answer
    
Thank you a lot, Anthony. – Francisc Mar 9 '11 at 14:45
    
TO be sure: I need to deselect all of these: ExecCGI, FollowSymLinks, Includes, IncludesNOEXEC, Indexes, MultiViews, SymLinksIfOwnerMatch? – Francisc Mar 9 '11 at 14:47
1  
you only have to deselect indexes – anthonysomerset Mar 9 '11 at 17:08
    
Thanks again, Anthony. – Francisc Mar 10 '11 at 11:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.