Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

during LDAP installation in ubuntu the following error has been occured.

"ldap_bind: Invalid credentials (49)"

can any one help me to figure it out ???

share|improve this question

migrated from stackoverflow.com Mar 8 '11 at 13:15

This question came from our site for professional and enthusiast programmers.

    
Did you fall prey to this problem? –  sarnold Mar 8 '11 at 6:26
    
wht do u mean by it ??? –  akb.zak Mar 8 '11 at 6:32
    
ldapsearch -xLLL -b cn=config -D cn=admin,cn=config -W olcDatabase=hdb olcAccess Enter LDAP Password: ldap_bind: Invalid credentials (49) –  akb.zak Mar 8 '11 at 6:40

1 Answer 1

Remove the LDAP database, re-configure slapd and restart it. Then add the ldiffs again. It worked in my case when I tried it on 9.04.

rm -rf /var/backups/*.ldapdb
dpkg-reconfigure slapd
/etc/init.d/slapd restart

and then add your ldif file again to DB.

ldapadd -x -W -D "cn=admin,dc=example,dc=com" -f ~/people.ldif
share|improve this answer
    
thnks Eshan i got an answer from stackoverflow.com/questions/3057257/… –  akb.zak Mar 8 '11 at 9:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.