Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am getting the following error:

2011-03-07 21:59:35.73 spid64 Autogrow of file 'MYDB_DATA' in database 'MYDB' was cancelled by user or timed out after 16078 milliseconds.  Use ALTER DATABASE to set a smaller FILEGROWTH value for this file or to explicitly set a new file size.

I did some research, and I found that for large databases you should set autogrow to a fixed size (MB), and not to a percentage. I feel like this database is not large and I may not be addressing the correct issue by changing this value. Does anyone have any opinions? Thank you!

I am using SQL Server 2008 RC2 running on Windows Server 2008

share|improve this question

migrated from stackoverflow.com Mar 8 '11 at 15:21

This question came from our site for professional and enthusiast programmers.

3 Answers 3

up vote 3 down vote accepted

You should not rely on autogrow to manage your day-to-day needs. You should be monitoring and growing the database manually during appropriate maintenance windows. Autogrow should just be your safety net for unexpected situations.

You could also look at setting up instant file initialization to improve the speed of growth operations.

share|improve this answer

You shouldn't relay on AutoGrow. It should be used as a safety net and nothing more. It should also NEVER be set to a percentage. Change it to 1 Gig, then manually expand the database so that there is enough room for the next few years worth of data.

share|improve this answer

Check whether you have instant file initialization enabled. This will greatly speed up your autogrow operations.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.