Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Solution : You have only one ruby version of ruby 1.9.2p180 (2011-02-18) [i386-mingw32] Problem Cause: Registry is still showing older version of RubyGems Solution Path: Remove all old version of ruby & dependencies (Note ensure to have all the back ups as your old apps on earlier ruby version which may not run after this solution)

Step 1: Go to command prompt & position at latest ruby 192 path Step 2: gem cleanup (Select Y for all prompts) Step 3: gem uninstall json Step 4: gem install json Step 5: Open user/app/GemFile and enter the line below under the line gem 'rails', '3.0.5' gem 'mongrel', '1.2.0.pre2' step 6: rails server Will boot from Mongrel & Rails 3.0.5

share|improve this question
add comment

1 Answer 1

Problem: To make default mongrel web server for rail 3.0 Solution 2: You have only one ruby version of ruby 1.9.2p180 (2011-02-18) [i386-mingw32] Problem Cause: Registry is still showing older version of RubyGems Solution Path: Remove all old version of ruby & dependencies (Note ensure to have all teh back ups as your old apps on earlier ruby version may not run)

Step 1: Go to command prompt & position at latest ruby 192 path Step 2: gem cleanup (Select Y for all prompts) Step 3: gem uninstall json Step 4: gem install json Step 5: Open user/app/GemFile and enter the line below under the line gem 'rails', '3.0.5' gem 'mongrel', '1.2.0.pre2' step 6: rails server Will boot from Mongrel & Rails 3.0.5

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.