Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've researched a lot on all the forums and this error is too generic for any of the proposed solutions to work. I'll try to give as much detail and tried solutions.

I'm running a CentOS PPTP server behind a Cisco WRT310N Router. Multiple clients from outside with different OS have failed with the same error 619, along with turning off windows firewall and disabling antivirus. I believe this is a router and IP routing issue, and not a client issue.

When I connect from a client on the same router as the VPN server, it works when I use the 192. network address- but doesn't work with the public IP address. I've tried telnet to port 1723 from an outside server and I get in. I've opened up the VPN port (1723) on the router, VPN udp port (500), and the GRE port (47) to route to the VPN server's ip.

Also, the server's router is behind a DSL modem. I had a glimmer of hope when this site: suggested that the PPoE authentication should reside on the router and not the modem. But I still came up empty.

So does anybody know what the problem is?

share|improve this question
I'm concerned you have referred to the GRE "port" instead of GRE "protocol identifier". These are two entirely different concepts. Have you opened TCP port 1723, UDP port 500, and IP Protocol 47 (no concept of 'ports' in IP protocol 47) from the outside to your PPTP server? – Jason Seemann Mar 14 '11 at 20:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.