Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just installed SP1 for windows 7 and I have severe performance degradation when connecting to SQL Server 2005 since then. Establishing connection takes more than 30 seconds while it's instantaneous on another computer. Firewall is disabled and I didn't make any change to the configuration. It happens both when trying to connect with a hostname and with an ip address. Everything else seems to be fine (for instance, I'm have no issue connecting to other computers with remote desktop)

What can cause such a problem?

Thanks in advance!

Edit : uninstalling the SP1 solves the issue instantly.

share|improve this question

3 Answers 3

up vote 2 down vote accepted

This comes from Smiley1244 from the MSDN forums but it is the answer:

To fix, run the following in an elevated Command Prompt: netsh interface tcp set global autotuninglevel=disabled

The complete KB 935400.

share|improve this answer
    
Please post a link to the original discussion on MSDN if you still have it. Thank you and welcome to Server Fault. –  Chris S Jun 3 '11 at 17:22

Ensure the firewall is enabled on both the client and the server, and the correct inbound exception is created on the server. There is never a valid reason to disable the firewall in Windows. Since its overhaul with Vista, the firewall has taken on additional roles in securing and authenticating network traffic, and I've noticed frequent issues with clients disabling the firewall to "speed things up" or "work around potential problems", and it's caused nothing but grief.

Regarding SP1 causing timeouts, depending on your client configuration you may need to reinstall SQL Server native client drivers, reconfigure system or user DSNs if you use them, or other things. I have not noticed any issue when using the SQL Server native client drivers when using connection strings in UDL files for client line of business applications, and we have a mix of clients running XP SP3, Vista SP2, Windows 7 and Windows 7 SP1 at the moment.

Unfortunately I cannot comment on your post to solicit additional information, so I'll just ask if you have any group policies that mandate or control authentication or encryption between clients and servers that would affect Kerberos/AD/Windows Authentication? I'm not aware of any changes in SP1, but that could also potentially cause an issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.